Device Connection Error

I know there are a lot of threads like this, but I can’t seem to find anything that fits my scenario exactly. My glowforge was working just fine yesterday, and while it was still on my wifi disconnected. So it was unplugged and plugged back in.

When the internet came back the glowforge would not connect. Everything else I have connects no problem. I tried creating a hot spot with my phone and with my laptop and I still got this same error message.

So hypothetically it can’t be my network. It has to be the glowforge right? This is just a frustrating time because I’m now working on making some inventory for an event I’m going to in a few weeks.

Thanks in advance to anyone that can give me any insight or reccomendations

1 Like

I would just re-enter wifi connection setup (hold button until it turns teal). I’ve had this happen before, and since setup take 30 second, it wasn’t a big deal to re-heal the connection.


Hey Henry, Thanks for responding.

Here’s the thing. I did that with 3 different networks. All of them gave me that same notification. My two hotspots were both right next to the glowforge when I did it as well. I’m waiting for an email response from glowforge since they seem to have more information about what it could be doing…

Yep, it sounds like the machine if a hotspot didn’t do it. That’s a bummer. :neutral_face:

1 Like

I’m hoping it’s something software or firmware related that can be repaired remotely, because it doesn’t make much sense with the timing

One thing I’m wondering is. I think my glowforge is overdue for a cleaning. Is there any way that debris is stopping the glowforge from working as a safety protocol? That and is there a way to do a hard reset?

Thanks again for the responses

Don’t know. I’ve never seen this one before, and it might very well be something they can reset from their end. I think you’re stuck waiting for them to get in and see your message.

For the cleaning…yes, always a good idea to keep it clean, and that’s something you can do while you wait…the guidelines are here:


I’ve gotten that message several times before when trying to set up on a router that was dual broadcasting 2.4 and 5ghz networks under the same SSID. It’s supposed to auto-switch and select the best network for the device, etc. and it’s not like the Glowforge can be assigned a connection on the 5ghz band, but it was never a problem when I changed to two dedicated SSID’s.


That’s exactly what I was thinking. I’ve got it about as cleaned as I can. The crumb tray seems like it would be very difficult to get as new. But between that and working on a few more designs. I suppose its all I can do for now. I’ve left it unplugged for now, so hopefully when I get back to it and plug it in, that will be all it needs.

Did you notice the post from @jbmanning5 just above yours? He suggested checking whether the router was dual broadcasting on both 2.4 and 5 gHz networks with an auto-switch.

If that happens to be the case, you’ll want to turn off the auto-switch if you can and assign the Glowforge to the 2.4 GHz network. He said he’s seen the same error message.

I’m not super well versed on my own Wifi, but I have two networks. One is Juno, and the other is Juno-5G So I would imagine that it has been split. But I haven’t had a problem for 3 months without any changes to the internet, so I can’t really understand it.

It’s so frustrating. These are the situations where having the ability to hardwire it and have a program that can run the Glowforge UI. It would really make the difference between a hobby machine and a machine for professional use.

Or even to print through the connection from the glowforge wireless setup system so that without internet it could still function.

Thanks for all of the input. Hopefully I will get a response sooner rather than later, and then hopefully it doesnt need to be sent in for repair.

FYI, I’ve found it doesn’t work as well ironically when the WiFi is super close. WiFi is a crappy protocol (sort of amazing it ever works actually) and doesn’t work as well when it perceives the base station “screaming”

1 Like

Thanks for running through some initial troubleshooting and providing those details. I see you already emailed us about this and I just replied there with some next steps, so I’m going to close this topic.