Did I reach the size limit?

Dad thank you1.zip (3.3 KB)

Ok my wife wanted to do something for her father. and on top of that actually get Beamer to help her out.

she created this list. we had to make it large so he could read it easily. I never could get it to render. Apparently I reached the upper limit? i was getting a WEB PAGE is slowing down CANCEL WAIT Dialog showing up. firefox browser.

It is a lot of text which I am wondering if it choked the system?

I shrunk it down substantially and then got it to render. however it turned out to be illegible. :frowning: I was up until 4AM waiting for it to get done. the text looked good with the mask on, Once I removed that things went down hill fast. :frowning:

Is there some way to know what the size limits are for the files, that I might have missed some place?

The buffer has a limit somewhere around 3 hours if I recall. One thing you can do is reduce the LPI to lighten the load.
SVGOMG has helped me reduce the size of some problematic files.


Well that seems to be what it was. I shrunk it down a lot and what I was able to print was 2.25 hours.

I wish there was some message that would pop up and say “hey buster that is WAY too big. you are going to have to make that smaller”


If you take note of the number of nodes in your file and run it through that link, you will see a significant reduction. There are also file splitting utilities that will break up your file into sections. Another way to accomplish that is to use different colors in your file that will show up in the UI as seperate ops.

How can I figure out the number of nodes prior to processing? I’m using Inkscape

Might try this?


Text can be wickedly complex when converting to outlines/curves; a ton of points. I couldn’t get your file to load on my end.

What I think I would do for engraving a bunch of text like this is make sure I have my design set up the size that I want it to be engraved at; grab about 1/3rd of the text and rasterize that section. Grab the next 1/3rd, rasterize. Grab the next 1/3rd, rasterize.

With the new higher speed PG engrave settings, you can get pretty much a full bed engrave in one go, I believe. But, if you have 3 images placed, that gives you the option of breaking the job up.


Well I ran it through the site @PrintToLaser suggested, I will have to give it a go later on. It was able to be rendered and did so quickly. and this image is MUCH larger than the actual engrave I did last night this am.

man in hurt going to sleep at 5 AM with a failure under my belt. :frowning:

1 Like

If nothing else, convert to a PNG file and see how long that will take to engrave (I turned off my machine and don’t have a time estimate). Make sure to rotate it before taking it into the GFUI. Actually, here is a version.

I set this one to 150 PPI which should be good enough. Good luck.


I hadn’t thought about changing the file type! Good Idea, and thanks for the upload. :slight_smile:

I will give this another shot in a few days when i can be around Beamer while he is running.


1 Like

Going to be a lot easier when I know more. LOL

I am still just going DUH at the idea of changing the file type to see if it makes a difference. I will file that away for future reference

Not thinking about changing file formats isn’t really a DUH moment. If you’ve been reading the forums you’ll have picked up that vector formats have a lot of advantages. Usually.

In this case, your file had so many nodes that it couldn’t process in the GFUI very well. I figured since you were going to be engraving anyway to get good quality text it could just as easily be a file that was lightweight that the GFUI processes much easier.

FWIW, generally go with PNG over JPG if you have a choice. Personal opinion and your mileage may vary :slight_smile:

1 Like

Thank you so much for the tips!


Thanks so much for the help, all! There are some great tips in this thread. @ca_worth, I’m so sorry you ran into trouble. I’ll be sure to pass on your feedback regarding error messaging.

As others have mentioned, it looks like your file contains a very large number of nodes, which may be leading to problems. Here is a trick you can use:

  1. Open your design in your design software.
  2. Draw a box around the text. Give it a stroke that is a different color than the rest of the design.
  3. Upload the design to the Glowforge app and open it. The design will open, but everything inside the box will be grouped.
  4. Set the box to be ignored in the steps bar and configure the settings of your design as you wish.

Could you try this out and let me know if it helps? Thank you!

1 Like

I will let you know how it turns out. we are closing on a new house next week and moving soon after. it will be a little while.