Did something happen to select all?

[see reply, it’s my fault]

I’m embarrassed to admit how infrequently I actually use my Glowforge, but life gets in the way. Anyway, today I finally had something I wanted to make, and either I’m completely misremembering how things worked, or something has changed since I last used it.

Specifically, when I press command-A (using a Mac, whether in Chrome or Safari) in the Glowforge app, instead of selecting all the objects, it selects the text on the web page. I’m 99% sure this was my usual workflow to position a group of things on the material, I’d cmd-A and then drag it. But now my only option seems to be to lasso everything or shift-click, like an animal.

Is it just me or did this change at some point for everyone? And if so, how did I miss all the wailing and gnashing of teeth?


I’m just going to live debug this, because it is just me… or at least, it’s something I’ve done.

I’m usually the first to tell people to try disabling extensions, but since this was happening in two browsers, and I had already tried turning off the ad blocker, I assumed that wasn’t the problem. But I just tried in an Incognito window and it worked, so I’m going to have to figure out what I installed that’s causing the problem.


And the culprit was: StopTheMadness. That extension causes a lot of problems, so I should have immediately tried shutting it off. If only I had remembered it was a thing.

Leaving this as a cautionary tale.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.