Discourse issue on ipad

I’m wondering if anyone else is having this issue: just in the last week or so, I’m seeing a huge slowdown of the website on the Discourse forum, on the ipad only. What I’m seeing is having to wait several seconds after clicking on an item, link, menu etc, before it reacts. Evidently there is some CPU intensive operation going on as at the same time my ipad gets pretty hot. This occurs whether I access the forum via browser (Safari, Chrome) or the dedicated Discourse app.

This is occurring only on the ipad, I’m not seeing it on desktop (Mac). I’ve got an M2 iPad Pro if that makes any difference. I also see this behavior on other Discourse fora when using the iPad. I couldn’t find anything on the Discourse forum that would help, but I might not be searching it correctly.

Has anybody else seen this, and have any idea what I can do about it? It has made using the forum on iPad quite painful, and that is the way I normally access it.


I’ve been experiencing this when reading the forum the last week or two. I use Safari on the IPad. It is maddening! It takes up to 2 minutes to get a reply box. Then 2 minutes to get to type anything. Once I hit the reply button … yep, another 2 minutes to send it.

Same thing to give a like. :disappointed:


I have been having this issue as well, but on Chrome with a Windows laptop. The forum tab will consume an entire CPU core for no reason, then I kill the tab and reload the page and it’s fine again for a while.


I have been seeing the same thing and, almost posted about it this morning. My iPad is not getting noticeably hot, though. It takes a solid 5-10 seconds to open a thread, 3-5 seconds to register a like, etc. It is making things slow enough that I have come close to just giving up and leaving all the new stuff unread the last couple days.

It seem to be intermittent. It will be like that for the entire time I am reading the forum but, if I come back to post or read something a few minutes later, it’s fine again for long enough to do that.

I am not seeing this at all on another Discourse forum I use. It’s just the Glowforge forum that’s slow.

I am using the Discourse app.

I haven’t tried it in a browser on the iPad but, I’m not surprised that it is the same. The Discourse app is pretty much just a customized browser that uses that same Apple-provided engine as all the browsers.

Any insights, @emilyhuh ?


Just reported this to the Discourse team to see if they can see what may be going on. I’ll let you know when I hear back. Thanks for flagging!


On my iPhone it always says that there is one notification when there really isn’t one. I deleted the app, reinstalled… still one notification, forever.


@evermorian @dan84 @ptodd @cynd11 @Aloha Discourse said that there was a Google tag manager issue that was causing the site to be slow and they fixed the issue.

Can you check now and see if it’s better?

Thank you!


It seems fine right now. It was happening intermittently for me, though. I will let you know if I have any more trouble.

Thanks for looking into it!

@cynd11 Thanks for posting about it!


Mine was an issue with the forum. The fix seems to have solved the issue after restarting the tablet. Thank you!!


It seems much improved right now. Time will tell!

Thanks for taking action @emilyhuh.


My computer was also running much slower too, but it is working just fine now. Thanks for the fix.


Great! Keep me posted if it acts up again!


This topic was automatically closed after 30 days. New replies are no longer allowed.