Displaced engrave

When I tried engraving this logo, the middle suddenly got displaced. This happened again when I tried with a different kind of wood (I tried PG maple ply and Baltic birch). The side tracks are clean as far as I can tell. Any suggestions on what went wrong?

1 Like

Looks like a belt tension problem. There’s a page on the support site for checking and adjusting it.

1 Like

Good suggestion, but that’s not the case this time. Both belts are taut.

In that case, it’s possibly a failing motor on the X axis, or the driver power supply. How old is the machine?

When you say both, do you mean the two belts on the Y axis and the one on the x axis under the gantry?

I got it in March 2018.

I meant both on the Y axis, but I just check the one the printer head runs on and yes, that one seems taut as well. I will say I cut a lot of acrylic so things get pretty dirty quickly, with a coat of sticky acrylic residue.

1 Like

I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.