Engrave jumps to the side almost 5 inches

I set up an engrave and cut that was supposed to be straight forward and a third of the way it jumped off to the right and continued several inches over as if there was no change. The design in the GFUI did not change. It did not hit anything, there was no other indication I saw that the head would not know where it was, I opened the lid and put in a ruler to show the distance of the jump and added a red line with arrows pointing it out, As you can see the beginning of the engraving is right where it is supposed to be. The time of the event is just before the time that is on the corner of the screen when I shot the image,

1 Like


Were you engraving a vector with higher than 1000 speed? I’ve seen this several time in my own work when using the beta speeds with vectors. Doesn’t seem to happen with rasters. Definitely a bug to squashed.


Seems like it has to be a belt tension issue. Just seems odd it would be a one-time issue. Have you checked it?

It is precisely that. A vector shape, 2500 full 1355 LPI. A standard now, though not great reasons for it here, It is the first I have heard of such a bug, Definitely not had it in more intricate designs,

Definitely a belt slip.

A loose belt was my first thought, but a one time leap over 4 inches and every other tight as a drum meant I thought immediately that it hit something but the centering was not off and the design was were it was supposed to be…

Just realized I had the thought backwards and tried running the design again. And sure enough the head was that 4+ inches from where it thought it was and instead of going back to its corner, it went to 4+ inches to the right of the corner so that is somewhat less weird than I had thought.

As that part of the wood is ruined anyway I am going to reboot the GF and run it again at super low power (same speed and lpi) and see f the bug shows up again

1 Like

If the material is ruined, why not run it exactly the same? Just move it a little on the bed and mark the previous attempt with a sharpie.

A “bug” would mean a commanded offset to the right. That should show up in the logs.

1 Like

It’s (the bug) had very few mentions.

1 Like

As far as I know it is a known bug. It was seen very often in one of the glowforge facebook groups and the current workaround is to rasterize the elements as it doesn’t happen with them.

Almost positive it is not a belt slip as it will not show up using the same settings but with a raster instead of a vector. It was reported a lot in one of the glowforge facebook groups when the beta speeds first came out.

Then it definitely should show up in logs (actually, in the code pushed to the machine).

I just ran it again and it did not happen. In this case I think that going to the previous lower LPI and lower speed would work rather than rasters but in other cases that are more intricate such as my “Avatar” pendants I occasionally need to run both vector and engrave when the deep engrave does not make it through from each side. but I have not had that issue before,

Extra weird! When I run the same designat slower speed and 450 LPI each piece is engraved separately where the higher speed they are engraved at once. Unless you made the two engraves as one image that locks the distribution, they will also be engraved separately.

In addition I cannot tell exactly but it looks like the 450 LPI part is wider than the same design at 1355LPI. The cutting time is similar.

I’m sorry that you had an unexpected result in your engrave. Thank you for providing very detailed information, the screenshot and the time & date of the first print you referenced. It’s great to see the discussion which has taken place here so far.

I extracted the logs from your referenced print on the 16th, and was able to confirm that the planned motion matched your screenshot of where you intended the artwork to be placed. Since you’ve already checked your belts, and they feel like they’re tensioned correctly, the best thing to check next would be the pulley located on right hand side of the underside of your laser arm.

Would you please share a photo of the pulley taken from an angle similar to this example?

Once we have this photo, we’ll take a close look and then advise on next steps.

Also, please let us know if you take any measurements regarding the possible difference in width between 450LPI and 1355LPI.

The look is certainly different but it is hard to measure. One measures ~0.10 and the other ~0.11 though there appears some crossover depending, The wider is deeper also so there is some accounting there but the piece that fits the slot fits tightly in the wider and not in the other. The 450 LPI looks rougher compared to 1355 so that may have some influence also.

The belt looks good as does all the wheels, and the fact that it was a one time jump would indicate that or they would not be so precise before and since the jump which was huge. The logic as best I could think would indicate a software bug related to the difference in the different procedures of engraving one at a time vs all at once since it was reported above that such is the only time the bug shows up, Though I have made several engraves of a very similar design at the high LPI and it has not. For what it is worth it made a 4.91 jump 0.8 inched into the engrave and not before or since.

I know you’re convinced it’s not mechanical, but compare the condition of the teeth on the X-axis belt to those on the Y. From the pics, there seems to be a big difference. Perhaps it’s just perspective, but given the amount of engraving you do, it wouldn’t surprise me if it’s just a matter of wear.

i would think that if the belt was warn and slipping it would not jump over farther than it should unless it was so worn that its own momentum was able to cause the belt to slip. wouldn’t it move less than it was supposed to? If it was making a bigger jump than needed i could see it possibly being the file or maybe if there is an encoder on the stepper that drives the head belt that it could be damaged or faulty.

The X-Axis belt has more smoke gunk that the Y-axis on the right side that never sees smoke, but it has never occurred to me to hose it down when cleaning.

I’m talking wear on the teeth, physical comparison of the shape between them.

I’m likely wrong, but the belts are wear items and without any other info besides your last pics, the one on your X axis looks very worn compared to the others (or mine).

Support is engaged and my opinion doesn’t matter. I’ve just seen CNC and 3D print machines need replacement belts.