Error loading file -help please


#1

I am getting a lot of load errors. I find that I have to break up my files quite a bit to eventually get them to load in pieces. Super fustrating. The files look crazy, I know, but there is not an unreasonable amount of data in them, and the files sizes are all under a megabite. Would someone be willing to look at my file, please, and tell me what I’m missing? Thanks ~Nate


#2

That design breaks down into about 7k objects when disassembled. That is a lot of chunks.
There are complex design limits, like about 3.5 hour or so, that can be changed somewhat by what exactly you do with a file. IE: lower DPI, Score versus engrave, etc.

But I suspect it is just too complex (and for the life of me I do not see why you would want to try and engrave or score this thing - sorry)…

Maybe someone at the Glowforge shop can break this down better for you.


#3

Yeah, I have to agree, that kind of thing might be too complex for vector rendering at this time. I tried all my tricks and they weren’t enough.

The only thing that worked was to rasterize it, 600PPI, transparent background, and it comes up with a really nice engrave for it. (You’d need to add a cutline back in if you rasterize it, or duplicate that one line first.)


#4

Thanks @Jules and @brokendrum. If I break the file up into enough pieces I can eventually get it loaded in. It only takes an hour to score the whole thing once it is loaded, so it isn’t too complex to cut, just too complex to load. Seems this could be easily addressed in software. The company I work for is moving much bigger data sets around through the cloud, so I know it can be done.


#5

I brought the file into AI, made it a single path (which really made the machine think for a minute), then simplified it just a skosh to reduce nodes from 7243 to 6699.

I think you made this in Inkscape so there is probably a scaling issue. I’m showing the artwork is 9.9927 in x 3.129 in but that is easily scaled.

I can’t hit print right now because my machine is down, but it loads in the GFUI in about 10 seconds (counting 1 Mississippi). It loaded even faster as a pasted item from AI.

See if this loads for you.

1v1_AI_mod


#6

That’s not a big reduction of nodes, but every little bit helps - I’ll try that, thanks @hansepe! Is this just an image file, I don’t see an svg. ~N


#7

right click and save as, it’s an SVG file.


#8

ah, duh. Thank you!


#9

I was just going to put it all into a compound path and see what happened. That’s what you did, right? Great minds…! :slight_smile:


#10

I just learned something today (compound path). Thanks!


#11

Thanks for the help everyone. Great advice!

There is a problem with our software in handling very complex files, and it looks like that’s what’s happening here.

I recommend using design software to reduce the number of nodes in your more complex design elements before trying again.


#12