Error on file upload (back to this noise again)

Saturday at 11:30am and I am back to this noise:

Screen Shot 2021-02-08 at 9.10.48 PM (2)

As before, I have:

  • Restarted the Mac
  • Cleared the Browser Cache
  • Tried both FireFox and Chrome (Latest versions)
  • Restarted the glowforge
  • Tried different files including ones uploaded previously.

I can open and run existing projects and I can create a blank project. If I open a new project and try to upload from there, I get the same error.

I can also upload via the web to Dropbox. This is one of several files I have tried:

It’s annoying when you want to be creative and the glowforge server decides it randomly wants to stop working for you.

Can you upload a very simple file? The file you attached looks very complex.

I don’t think it is the server causing the issue; I suspect it is either your internet connection or your image causing the issue.

I think you have a bad wifi connection.

I just attempted to upload a rather complex file with a variety of steps and image types and didn’t get a problem, so I think you will need to look at your file and your internet connection to resolve this issue.

Sigh… just skip it. It will either solve itself eventually like it typically does or not.

Close this ticket

Maybe look into a wifi extender or a different modem? The GF is so picky about a strong stable signal you will save yourself a lot of grief.

1 Like

200mbs download and 10mbs upload. WiFi is stable enough for gaming and video without drops. Uploads to other file storage services work fine and this error occurs when uploading to the glowforge servers, so the WiFi connection to the Glowforge itself is irrelevant (you can still upload a design when it’s powered off)

I downloaded the file from your original post and uploaded it to a new project with no problems. It took a little while but it uploaded fine.

I suspect that your internet connection may be to blame, speed or otherwise. It could be that the upload dropped a few packets or there is a link between your PC and the GF server that isn’t perfectly stable.

So not the GF server, not a problem with the file. I think that it is likely the error message told you exactly what happened - there was an error with the upload that the GF server received. By telling you to try again later the server is saying that it is likely a connection instability issue which may be resolved by giving a little time and trying again.

This happens and affects everything, not just GF.


I can see why you think the other network traffic working means it’s a GF side issue, but gaming and video local clients both have buffering systems built in to minimize network stability issues being visible to the user and Dropbox will just keep trying and trying. GF for some reason doesn’t seem to. (Advertised or even measured up/download speeds don’t speak to constancy of throughput stability, especially if a network supports multiple devices)


I’m so sorry to hear that you’re running into trouble, but I’d be more than happy to assist.

Based on the design you provided, the trouble may be related to the complexity of the design. I’d like to take a look at the design file to see if we can help resolve the snag. Could you please upload the design to this thread for us to review?

Once we can review the file, we’ll send over any additional steps.

What I uploaded was the design file. I just wanted to engrave that image. Are complex photos a problem for Glowforge? If so, what makes a photo “complex?”

Thank you for confirming that the exact image is the one you were attempting to upload, and not a design file from illustrator or inkscape.

I’ve download the image, and uploaded it via the Glowforge App. I did not run into the same error, and I was able to prep the image to print.

I know that you’ve mentioned that the trouble seems to occur when creating a “new project” and uploading this file. Is it only occurring with this particular image, or any file you attempt to upload in this manner?

When the issue is happening it seems to affect all uploads to GlowForge’s servers. I can upload to other services (Dropbox, Google Drive, Wordpress, etc) without issue.

If it happens again I will plug directly into the router to see if it is WiFI only.

Thank you for updating us. I’m sorry that this has continued to occur. I sincerely apologize for the delay in response.

It can be difficult to narrow down snags regarding uploads, without multiple instances of it occurring. I’d like to see if we can capture a more exact date and time of when this happens, and see if we can extract some logs to review the behavior you are seeing.

Could you let us know the next time this occurs, with the date and time so we can investigate deeper?

Using a direct connection vs a Wi-Fi connection may yield a more consistent connection, so please let us know if this changes any of the behavior.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email