Eternal Calibration

ETA: moving this post to avoid cluttering up the queue.

I’ve seen this problem in the forums quite a bit, but thought I’d see if anyone has tried anything I haven’t and had it succeed! My machine has been calibrating for three days. It started in the middle of a project and hasn’t progressed past that since. I did all wifi/wifi related device resetting, reset the machine, reset my computer, checked to make sure the camera was attached properly, let the machine sit off overnight in case there was a heat issue, etc etc.

I’ve contacted support, and they asked for a photo of the gold pins, which I sent and I’m still waiting for a response on that.

The light is yellow, and it says calibrating. The head doesn’t move at all.

Are there any other things to try?

Did you try covering the GF glass on startup? Sometimes lighting is an issue.

Did you move the laser head to the center before turning on?

What sounds does it make when it starts? Does it make the ‘click-click-click-click’ sound of the lens moving around?

Is the machine empty? No materials in the bed (especially none with things already cut out of it).

I’ve tried everything except covering it, which I’ll try now. It’s not making a noise beyond the general sound of the machine being on.

No click-click-click is a sign that it’s maybe not getting a solid wifi connection.

That has been resolved in some cases by changing wifi channels on your router.

Have you tried to pull the log files off the machine?

If your light is yellow, that indicates a potential machine issue and removing material etc won’t help.

Do any of the pins look bent? Is it making a firm connection and locking in when you plug it into the head?



I’ll try switching my router channel. I checked a log in the terminal on my Mac, but I’m not 100% sure what I should be looking for there.

As far as I can tell the pins look good and it seems to lock in tightly. I might try to attach again.

I’d listen to @jbmanning5, he knows more than I do for sure.

Here’s the discussion involving wifi channels. (longshot)

1 Like

Thank you. I tried a switch and it didn’t help. Hopefully tech support will have some insight for me eventually.

A lucky guess every now and then.

The yellow/orangish light is definitely an indicator here that the machine is sensing a problem. You get it when the machine is too hot, but you also get it when something important is disconnected/not connected properly/broken. Unfortunately, the only UI status message that pops up right now is the one when it’s cooling.

The logs will generally give an indication of what is going on, or what it thinks the fault is, but it can be a little work to decipher. It’s kind of like a car, one fault upstream can cause multiple faults downstream.


The log file that @evansd2 was referring to above is not the Mac console log, but rather the internal log in your Glowforge. See his link above for how to get that log (it requires doing a reset of WiFi on your Glowforge).

Just a note on this, you don’t actually have to reset the WiFi. You have to enter WiFi setup mode and connect to your Glowforge via browser to download the logs, but if you push the button or power cycle the Glowforge, your network will still be saved. IOW, you are good as long as you don’t go into the set up and overwrite the existing WiFi.

1 Like

Oh, that’s good to know!

Thank you for the info! So I’ve done that and what I see is a lot of files that say ‘transfer fail’ and ‘bad file’. Does anyone here have any insight into what that means?

I’m really hoping it’s something I can fix on my end, and not a hardware issue since it looks like they won’t have more Pros available till February (I haven’t confirmed that, just something I saw on FB) and that’s just depressing!

The logs are/can be a slippery slope and kind of scary looking. There are a lot of files in there, and the errors can compound downstream (one system upstream affecting downstream systems). They are better than they used to be though - they used to not be organized into directories etc so different systems would write to different files all in the same directory and you’d have gaps in the dates they were written into the file, etc.

Since you’ve got a ticket open, you might go ahead and email them to support (if they haven’t already pulled them - if your machine is online they should be able to). I wouldn’t post them here since they have some machine specific tokens inside, I believe.

1 Like

Ok, thank you. I’ll send a follow up to the support person I’ve already had contact with.

Unfortunately, it looks like your unit is experiencing an issue that we can’t resolve remotely. I want you to have a reliable unit, so I’m recommending we replace or repair this one. I’ll be in touch via email to sort out the details. I’m so sorry about the bad news.