External Air filter just beeps. Won't work

I’ve replaced the air filter cartridge and I’ve tried replacing the fuse. The air filter just beeps then…nothing. I’ve reached out to @glowforge and crickets. Anyone else had this issue and can provide a solution? Thank you!

Was it working before and just started beeping or is it brand new and has only ever beeped?


It was working before. I’ve had the air filter about 1 year. I stopped using it for about 3 days until my new cartridge arrived. I changed the cartridge and turned it on and it just beeped. I then researched and saw that I may need to replace the fuse. I did that and again, nothing.

I don’t have an air filter but it sounds to me like there should be a reset button to let it know the filter has been changed.

Finally heard from @glowforge. If you turn the fan knob, it will kick on. You live and learn, I guess. Thanks all.

1 Like

Thanks for updating us on how you fixed it. Now, you may save someone else some time in the same situation if they come across this discussion while searching.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.