Extremely laggy

I’m trying to set up a job but all of a sudden its really laggy
I tried to create an outline and it just sat there acting like it was loading and does nothing
I also tried to export the design and nothing is happening.
It’s not my internet because everything else works perfectly

My first act would be to reset the network. For most issues, it’s usually something with your wifi. That being said, you can have decent internet and still have issues as speed also depends on the traffic coming and going at the servers.


A quick check of the GF servers shows no problems at this time so I’m suspecting your network. (Some days I have to reboot mine several times for optimal performance). The GF uses the 2.4 gig band which is crowded and easily disrupted. It could be as simple as someone using the microwave or a cordless phone (even a close neighbor). I struggled for a long time with an intermittent issue that would stop my lasering cold. It turned out to be my Apple TV. I moved it to its own channel and never had another problem with it.


This is a browser issue not talking with the GFUI servers to process the commands. I’d try refreshing, closing and reopening the browser, and/or clear the internet cache on the machine and see if that helps.

Also, we’re pretty sure the GF server status page is not automated but is manual so if they don’t know, they page won’t reflect it but we’ll know about it trying to use it and it failing. Checking directly for google server issues can often be more handy.

And I’m not sure which service GF uses but….there was a disruption on Google compute services.



Hi @MorningstarMSI I’m sorry to hear that you’re continuing to run into some trouble with your Glowforge and the outline function in the Glowforge app. I saw that you had created another thread previously to address similar trouble with outlines on a design:


I saw my colleague, David, posted a response to help collect more information for troubleshooting in your other thread. To avoid any potential confusion or miscommunication, I am going to close this thread so we can consolidate and continue troubleshooting through your original thread. We’ll look forward to your next response on there to help you get this resolved soon. Thank you!