Filter out of the box does not start up?

Just received a filter unit and out of the box it doesn’t start up, tried messing with the setting knob on the side, and another power cable / multiple electrical outlets. Can’t get the thing to turn on.

Fan does not run, removed the filter unit and tried to run it without the top on and unit does turn on in any conditions.

Please help <3

1 Like

Update: replaced the fuse close to the electrical outlet (there was a spare fuse inside the tube close to the slot) and no avail. Still does not power on.

1 Like

Sorry for your troubles. Someone from support should be with you soon!! Welcome to the forum!

Thank you :slight_smile:

Oh no, I’m sorry to hear about the trouble with your new Air Filter.

I’m going to need some personal information from you, so I’m going to follow up with you via e-mail.

I’ll close this forum post once I’ve heard from you over there.

My filter fan has stopped running as well.

I attach the hose to my GF, turn the filter on and nothing happens. The switch illuminates and sometimes it lets out a couple of beeps, but not always. No airflow - the fan doesn’t spin at all regardless of the adjustment knob position. I’ve barely used my GF - maybe 20-30 pretty simple prints. Help, please.

It’s best if you create your own new post to problems and support as they only create one ticket per post at a time and will not be able to address your problem here.

Hi @annalayzabusiness - It looks like we’ve since been able to get you taken care of via email so I’m just swinging by to close up this topic.