For you inkscape users

tools
software
inkscape

#1

Here is an inkscape extensions that traces centerlines instead of edges.
Might be useful when working with file to be 'forged.


Collection of Useful Inkscape Extensions
#2

Thanks, for the link.
It would be good and have one thread for all the inkscape files, like the one for the box generator.
I may just try and put that thread together.


#3

I’ll take “Things I Didn’t Know I Needed” for $10k, Alec.

Thanks!!


#4

I tried to get this to work with inkscape in Windows, but I did not have much luck.

I downloaded the zip file and put it’s content in the inkscape extension folder. But when I run it, I get the error:

ImportError: The _imaging C module is not installed.

Did anyone manage to run it in Windows? If so, what steps did you take to install it?


#5

Similar error, but I’m not into Python and wouldn’t know where to start … this is the full text:

Traceback (most recent call last):
File “centerline-trace.py”, line 392, in
e.affect()
File “C:\Program Files\Inkscape\share\extensions\inkex.py”, line 268, in affect
self.effect()
File “centerline-trace.py”, line 359, in effect
path_svg,stroke_width,im_size = self.svg_centerline_trace(filename)
File “centerline-trace.py”, line 154, in svg_centerline_trace
im = im.convert(mode=‘L’, dither=None)
File “C:\Program Files\Inkscape\python\lib\site-packages\PIL\Image.py”, line 653, in convert
self.load()
File “C:\Program Files\Inkscape\python\lib\site-packages\PIL\ImageFile.py”, line 155, in load
self.load_prepare()
File “C:\Program Files\Inkscape\python\lib\site-packages\PIL\PngImagePlugin.py”, line 339, in load_prepare
ImageFile.ImageFile.load_prepare(self)
File “C:\Program Files\Inkscape\python\lib\site-packages\PIL\ImageFile.py”, line 223, in load_prepare
self.im = Image.core.new(self.mode, self.size)
File “C:\Program Files\Inkscape\python\lib\site-packages\PIL\Image.py”, line 36, in getattr
raise ImportError(“The _imaging C module is not installed”)
ImportError: The _imaging C module is not installed


#6

I’ll work on it this afternoon. Here is a link that might lead to a fix.


#7

Hopefully I have not created more problems then solutions by posting this (untested by me) code!


#8

I give up. Between several versions of Python on my computer, 64 bit issues and two versions of Inkscape, I’m at a loss to figuring out this issue. Part of it is the way Python modules are installed. Had to try and figure that out. Then figuring out the difference between PIL and Pillow and then the locations for Inkscape. Arg. Will try it out on Ubuntu tonight.


#9

Cheers, I’ll have a go at “pillow” myself. If it is a 64 bit problem I might just try installing and running 32 bit versions.


#10

No errors messages after installing PIL on Ubuntu. Just crashed Inkscape twice. Not working for me.


#11

I installed it on Mac and didn’t get any errors… but it keeps crashing Inkscape when I try to use it because it says its size cap is getting exceeded…

Super sad. I want one of these.


#12

Yeah, I’ve never gotten Inkscape to work more than 10 seconds on MacOS.


#13

I only have mac. Seems to work great


#14

Just a thought, did you install the latest Quartz X11, I had that problem with Inkscape, I reinstalled X11 and it worked great.


#15

Right - for El Cap and macOS, you must have the very latest version of Quartz X11 installed.


#16

Inkscape works great for me on Mac. It’s just this extension. Every time I try to have it trace the center lines, it crashes Inkscape altogether. Which is dirty pool, because Inkscape is awesome.


#17

Sadly, not all the Inkscape extensions are Mac-compatible, and since they tend to be community-contributed modules, little incentive to do so.


#18

Ahhh… This is a fabulous point.

That’s okay. As my father once said, “They can drag my Mac from my cold, dead fingers.”

(Or, at least that was our family motto before Willy Wonka, I mean Steve Jobs died. I suppose we’ll have to move on eventually…)