GF does not connect to WiFi

Can anyone help when the Glowforge does not connect to the WiFi for no apparent reason?

thanks in advance

Hmm, if I were in that situation, there are a few things I would investigate. What’s really happening when you’re looking at that page is that the browser is, in the background, trying every few seconds to connect to an internal web service that is only available when you’re connected to the Glowforge’s temporary WiFi network.

I can think of a few things that could prevent that from working:

  • Something in your browser is blocking the connection (e.g. an ad blocker or other content filter)
  • Some kind of network stack problem on the Mac preventing it from fully connecting and obtaining an IP address from the Glowforge
  • A problem on the Glowforge itself such that it’s not properly serving DHCP or HTTP

I’d address the first by making sure I’ve disabled any content blocking in my browser. And for the second and third, restart the computer and the GF and try again.

If you really want, after you’ve connected to the Glowforge WiFi, you can hold down the option key while clicking on the WiFi icon on your menu bar, and you’ll see some additional debugging information. For example, it will say what the IP address and router are. I’m not at home with my Glowforge so I can’t be sure, but I think it would be some 192.168.192.x address, and the router should probably be

Another thing I’d look at, as a nerd, is the browser’s JavaScript console (in Chrome: View > Developer > Javascript Console). You should see it spitting out a lot of messages that say things like:

action DEVICE_NOT_FOUND @ 09:38:16.460
action FINDING_DEVICE @ 09:38:18.454

and maybe some other information that, if you posted it here, could give someone a clue as to what is going wrong. But that’s all just while waiting for Glowforge Support, who are probably the only ones who can help here.


It never occurred for me to check AD-BLOCK, @chris1 You are a Genius!
All my devices have some sort of ad block enabled, disabling it fixed the problem!
Thanks again!


Thanks for the help @chris1!

@TheAlikA I’m sorry you ran into trouble getting your unit connected, but I’m glad everything worked out! I’m going to close this thread. If you run into any other trouble please open a new thread or email us at and we’ll be happy to help!

1 Like