GF doesn't go through initial startup routine

Yesterday my GF Pro showed up as “offline” when I powered it up. When I turn it on, the lights come on, then after about 20-30 seconds I get the usual “muhaahhh” sound for a couple of seconds. It should then move the head and start it’s usual startup routine. But nothing happens. I’ve checked all the connections and all seems solid. I’ve been using this machine almost daily for about 3 years without any problem.


Have you tried setting up the wifi again? Have you tried using your phone as a hotspot and resetting the wifi?


I’ve rebooted the router. No change. If anyone knows… Does the next step in its routine require a network connection before it proceeds? It says “offline”, but I’m wondering if during it’s startup if it will not continue unless there is a connection? My signal is very strong in my shop on my mesh network, so I know its not because of a bad internet connection. I’m going through the initial wifi setup now just in case.


OK… I just went through the connect to wifi procedure and it now seems to be working! Strange that it lost it’s connection for the first time since this machine was put into service.


I actually kind of doubt it was Wi-Fi. There’s two major things that can cause that to happen:

One is if you have material in the Glowforge when you start up, especially material that’s already been cut once or twice, it can really confuse the Glowforge start up and make it do weird things

But two, which is what I think probably happened, is that it was too cold. If your Glowforge was chilly it will do this weird kind of start up where it gets a temperature Out of bounds error and you get a yellow light on your button. It doesn’t necessarily throw an error in the interface either, it just makes weird noises and stops doing things. Does this seem about right?

If you walked away and things warmed up, it would just start to work again like magic. You have all the symptoms.


Mine won’t go through the centering/focusing procedures until my wifi is connected.

Or maybe, connected to wifi and the app. I never notice that since my computer is usually on, but i can tell when it finally connects because i see the interface start to change, then it goes through the centering and focusing.

For me i know it’s my wifi connection rather than other external factors.



This is what happens when you power on a Glowforge Performance Series laser:

  • Boots a Linux kernel
  • Reads a config file from the integrated storage
  • Opens communication with the print head and initializes a bunch of sensors
  • Powers up the coolant pump, stepper motors, lid lights and lid camera
  • Connects to the Glowforge’s cloud servers
  • Checks for firmware updates
  • Downloads the HUNT motion file from the cloud, which tells the machine how to calibrate the focus mechanism in your specific print head to get the lens to its “home” position

That’s the very start of the startup calibration sequence (“focusing”, “scanning”, “centering”, “homing”), the first time anything moves. The next step is to have the lid camera take a picture and send that to the cloud, to start the process of moving the print head around until a picture shows it is perfectly centered under the camera.

If the machine can’t connect to the cloud because it’s not on your wifi network, it can’t make it to the first point where anything moves. So it’ll just sit there, coolant pump running, lights on, waiting for an internet connection to get started.


This topic was automatically closed 32 days after the last reply. New replies are no longer allowed.