GF is Offline, after successful wi-fi connection

I got my replacement GF today. Unpacked, set up, all good. Ran through the wi-fi setup, and got the success message. But, it is still saying “offline” in the app. I have the replacement set up in the exact spot I ran my old one for almost 2 years, with no wi-fi problems. Wi-fi router desktop all in the same spot… no problems getting good signal for the computer. I have tried resetting the wi-fi, rebooting the computer, and turning the GF off and back on. Still, no luck. Any ideas?

Make sure that you have selected the new Glowforge from the drop down menu showing printer names. It is likely your old Glowforge is the default.


I’ll double check that, thank you!

That was absolutely it!!! I didn’t even know there was a drop down menu there! OMG thank you so much. almost 2 years into this and still learning!


I am using the same GF, but mine says it is offline. I have followed all the steps for resetting and nothing seems to work. WiFi signal is strong and I even moved the GF closer to the router. What else can I try?

Welcome to the forum.
In order for Glowforge support to help you, you will need to start your own thread. In the meantime, was your Glowforge working ok and now suddenly it is showing offline?


How frustrating. Have you read the official troubleshooting that Glowforge provides: Glowforge is "Offline" – Glowforge


@tkayenovak1 I am so sorry your printer was saying it is offline but I’m so glad to see that you were able to resolve the issue with the help from our amazing community. I am going to go ahead and close the forum post since you were able to resolve the issue.

@mrslindabarnes I am so sorry you are running into issues connecting your printer as well. Please create a new forum post or send us an email and we will be more than happy to assist you.