GFUI is resizing/rescaling my SVG file. Why?

svg
gfui

#1

I’m trying to print a file I first created in Fusion and then finished in Illustrator. I exported the file as an SVG and when I upload it to GFUI, it displays the image about 70% of actual size.

Yes, I know I can resize with the drag handles, but I need to engrave/cut with very precise dimensions for my project. I re-imported my SVG file back into Illustrator to double check if I had done something wrong, but AI shows it being the correct the dimensions.

Is there something I’m doing wrong? I could use some help here.

I find the GFUI very imprecise, buggy and frustrating. Yes,I used to design GUIs for applications previously in my career. (Don’t even get me started with the UI for Inkscape on a Mac. Yuck!) :nauseated_face:


#2

I’ll bet anything you have the “responsive” option checked when exporting the SVG. Turn that off and everything will be the right size.


Exported images from illustrator get sized incorrectly
#3

Chris, you’re a genius! That took care of it straight away.

Thanx. I owe you a beer!


#4

Heh. Only because others have been there before. It defaults on, I guess everyone is designing for the web these days. But the resulting file has no size units, so there’s one place I can’t blame the GFUI.


#5

Um… I thought the UI was the same between Windows, linux, & OS X. I know OS X actually runs the linux version inside an X11 shell emulator (xQuartz). Sure, the “outer” MDI elements are different between Windows and X11, but the actual UI (I thought…) was the same. Not trying to start the Crusades – just very puzzled by your comment. :thinking:


#6

I have gotten something similar. I was using SVGOMG to clean up my svgs but the last few times it has “shrunk” the object defined in the svg. Any ideas? :slightly_smiling_face:


#7

Thanks for your help, @chris1. I’m glad it worked out!

@gernreich, your question is out of our team’s scope. If you post it in Beyond the Manual, you might be able to get some helpful advice from the community.


#8