Glitch in the matirx

After uploading my earring design into the GFI I noticed the sides are warped. I check in my illustrator version and the lines are perfectly straight. I’ve deleted the file in GF and re-uploaded it. I’ve shut the machine down and re-started it. I’ve re-saved the file and re-saved under different file names. I even deleted the outline and redesigned it all together in Illustrator. Each time it loads up, the outside line gets bent/distorted. I’ve included screen shots. The green line in Illustrator is just there to show reference that it really is straight.
Any idea on how to get this to stop happening?

That might just be a visual artifact of the camera fisheye correction. What happens if you cut the file?

On second thought, even the thumbnail looks like it has the curve. Are you certain that your file didn’t get modified or corrupted before you uploaded it?

it cuts crooked

1 Like

clearly i have or GF has an issue here. I started a whole new file from scratch. Now the cut line is distorted in a different way. Pic one is Illustrator and pic two is GF

Strange. What happens if you just upload the outline?

If you can share a sample .SVG file that does this, it will probably help the folks at Glowforge to debug the issue.

Is the feather a raster image or a filled vector? (And if it is a vector, try rasterizing it before saving the file again.)

That is very weird. Support will likely ask you to share the file so they can take a look. I’d be happy to as well if you care to share publicly. I see in the second post, the left side cut is not lining up with the cropped feather engrave as well.

(It’s got nothing to do with the camera or the machine. The screen representation of your file has nothing to do with the bed image - the machine doesn’t need to be powered on to use the UI.)

It was a filled vector. After you suggested, I did rasterize it and it’s still distorted.

I’ll attach the file. The two pieces on the left do not distort but the two on the right do. feathers (1.5 MB)

That’s weird. The UI won’t open an AI file for me - “This type of file isn’t supported”

If I open in Inkscape and save as SVG, however, it comes out perfectly:

Try this?
feathers (118.2 KB)

(Vector vs. Raster wouldn’t make any difference. Objects are processed separately, one doesn’t affect another.)


Thanks. It did work. I also tried a whole new feather image and it worked fine. Maybe the original feather image didn’t jive with me for some reason. Thanks!

1 Like

Sounds like you might have a workaround, but my only other thought is your export to svg settings. Do you have responsive checked (uncheck it if you do)? And what decimal number do you have in the export box?

it is unchecked and the decimal is at 2

You could try upping the decimal to 5 or 6 and see if that makes a difference…wondering if it could have to do with it not interpreting the correct coordinates on a small object? :man_shrugging:


Not sure how that matters when the same .ai file opened in Inkscape then saved as SVG works fine?

Export from AI to SVG from within AI could be losing decimal precision. Inscape doesn’t necessarily recognize or respect the preferences for AI. Those preferences probably aren’t even stored in the .AI file.


Not sure what is causing the distortion but if I copy/paste your file artwork directly from AI to the GF dashboard it seems to be straight. (I didn’t try exporting & uploading an SVG)

1 Like

Yes, this is what I was thinking-that it’s losing or distorting information in the export as SVG process. It sounds like everything is good on the AI file side, so it would appear the ‘glitch’ is being introduced either in the SVG export or the GFUI import. I didnt see your original svg, but that would be a way to test-open it in AI or Inkscape, etc. and if it looks good then GFUI is culprit, if the SVG is bad in any program then the AI export is the culprit.

Even in your screenshot, the right side feathers aren’t lined up correctly like they are in Inkscape and in my screenshot from the UI.

1 Like

I’m sorry you ran into trouble when importing your design into the app. It’s great to see that the advice @eflyguy provided got you up and running with this design! Thanks Eflyguy!

I’m going to close this thread. If you run into trouble again, or have any questions, please post a new topic or email us at and we’ll be happy to help.