Glowforge App Crashing

Hi, I have already contacted support, but they told me it my problem isn’t on their end but rather on my end due to software or something and I am at a complete loss.

My computer just recently updated to Windows 10 Version 21H2, and ever since then I can no longer use the glowforge app to open up any of my design files. These are all files I have used and printed in the past with no issues, so it isn’t a file problem. I will put an image below of the error I keep receiving after about 30 seconds of having either all of my design files showing on the main page, or when I open individual files. It doesn’t mater which file I have open either, it crashes on everything. The files open on my phone with no problem and print them, so I have confirmed it isn’t the files that are the issue.

Has anyone else encountered this same issue? If so, how did you fix it because support told me they can’t provide any suggestions since it is a local software issue.

Something has changed for you - either a browser update, an ad blocker update or something similar. Try opening the app from a different browser, or open the app from you phone.

3 Likes

There are a few of us having issues… GF said it was either antivirus or ad blocker… but nothing has changed for me and I’ve been having this issue for weeks on and off now

Hi, i’ve tried opening the files from my phone, and that works just fine, but nothing I do on the computer works any longer. I have tried opening it in microsoft edge, chrome, and firefox but none of them work.

The only thing that has changed on my computer is that it updated to Windows 10 21H2, but I have all of the antivirus settings integrated into Windows 10 turned off and deactivated so I don’t think it would be that. My antivirus I have always run is exactly the same and hasn’t updated or changed settings from the last time I was able to use the online app from my computer.

I’m not sure where to even start looking beyond that to fix the issue.

Open the files from your phone and while you sit with the Glowforge as it prints, fuss with your computer. I suggest Chrome running in safe mode and see if the app will open. I am running very old OS because whenever something updates things get messed up.

4 Likes

I’m willing to help test and see if a file or two crashes on my end. I work in IT so this is the kind of testing I do on a regular basis

2 Likes

I think the problem is that the app crashes - not the file.

1 Like

Is there a way to back-up from the installation to the previous or reinstall the variations? Beyond my knowledge off the top of my head. I got pushed into V-11 and have many issues but that at least is not one of them.

One of the de-scrambling programs might be of interest.

This is exactly what I ended up doing, using my phone! I think I managed to find the right setting to click while I was printing my files and the website hasn’t crashed in a while for me.

I think the Windows 10 upgrade broke something for the redirects / pop-ups, so thank you so much for suggesting I look at the pop-ups! I changed the setting to allows sites to send pop-ups and use redirects, and when that worked for a bit, I added it to the exceptions since I don’t like to leave that as an overall setting. Never been an issue before, but with the windows update it suddenly didn’t like it.

For anyone else having the same issue, this is what I did for settings in Chrome in case it helps anyone else out! Temporarily it is working, but I will have to wait and see if it is the long term solution.

5 Likes

Thanks for sharing your solution. I am sure there are others trying to figure this out.

3 Likes

Same problem here. It’s a pain…