Glowforge connection issues

I have owned my Glowforge for about a year, but have not had much time to use it. I cut a few things the other day and all worked fine. It is now offline. I looked up fixes for hours. I have tried shutting down. using a phone hotspot, reconnecting wifi, etc that I have seen as solutions. It appears to be online. The setup screen says it is connected. Machine turns on, but arm does not move. It doesn’t really do anything but turn on and button is teal. App screen shows last piece of draftboard that I cut a few days ago although it is not still there. Please help! Sonya

As long as the button shows teal, the setup isn’t finished. Did you get confetti and huzzahs?

1 Like

I looked all over the pasta section at the grocery and never could find that one.


If the button is teal, it’s in wifi setup mode - you didn’t complete the process. (As stated above.) A quick check of wifi networks from a phone or laptop will confirm, the Glowforge wifi only appears when in wifi setup mode.

I did get the huzzah, and it said I was connected. When I open the app, it uploads the design but says offline. It also shows what I cut last time( the piece of wood).

1 Like

Hmm…now button is not lit and Glowforge WiFi is not visible in list of available networks. Still offline though.

I’m so sorry you ran into trouble with connectivity.

Could you please try the following steps?

  1. Power Up: Turn your Glowforge off. Then turn on your Glowforge and wait about 30 seconds.
  2. Start Wi-Fi Setup: Hold down the button on your Glowforge for ten seconds, until it glows with a teal color.
  3. Sign In: Using a Wi-Fi device like your laptop or tablet, go to and sign in.
  4. Connect Your Glowforge to Wi-Fi: Follow the instructions at to connect your Glowforge to Wi-Fi. If you run into trouble along the way, let us know what happened right before the issue arose.

I’m including our Wi-Fi troubleshooter just in case. Let me know how it goes!

I tried again yesterday. I had followed those 4 steps several times the day before. It worked yesterday and I am able to use the machine! Thanks so much for your help!


I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!