Glowforge connections issues

I have been having glowforge connection issues for the past couple days - I couldn’t get connected at all yesterday, and today I was able to connect for a short amount of time but lost the connection again before I was able to get anything printed. I tried resetting the wifi, but the button never changed colors and nothing was initiated. I also attempted a factory reset, but again had the same issue where the button wouldn’t change colors. This was all before my connection was restored earlier. I tried pinging the website from my computer and had no loss issues, checked my internet speed - nothing worked. Now, when I power it on the glowforge does not even begin the calibration sequence that it always initiates when I start it up. I assume the earlier issue may have been due to the update being downloaded and installed, but since the issue is repeating itself, I’m at a loss. What should I do at this point?

So now when you turn it on and open your GFUI, does it say online? If no, I’d hold the button down and go through the connection again - it’s possible that you managed to clear it when attempting the reset.

If it does say online, but you’re not getting the follow up go through the steps here to try and verify if your WiFi is the issue.

If not, you may be having a cable problem, which is much more complicated so hopefully it’s WiFi!

1 Like

Hello @boredlumberjack,

Thank you for reaching out to us. I sincerely apologize for the delay in getting a response to you. Based on your description of the offline trouble you’re having in addition to the button being unresponsive, I’d like to have our Senior Tech Support Engineers take a look into this issue for you. I’m sending your ticket over to that team now, and you should hear back from them soon.

If anything changes in the meantime, please let us know. Thank you!

1 Like

Thank you for all the details, @boredlumberjack. I’m sorry for the trouble with this. It looks like this may have been caused by a rare complication with a recent firmware update. The primary symptoms for this issue are excessively long initial connection times, and an unresponsive button during those periods. We’ve made a change that should take care of this issue for you.

Could you please turn the Glowforge on, leave it on, and reply to me on this thread when you’ve done so? Since there may be an unusually long time needed to connect right now, so you may need to leave the Glowforge on for some time in order for the connection to be established before the update can download and be applied. I’ll take a look from my end when I hear back from you.


Thanks for the reply vee - the long wait times seems to be the issue from what I’m observing on my end. As of writing this I have just turned my glowforge on. Additionally, I tried to use it again yesterday, and on my first attempt it connected immediately, and I was able to run a print. However, at the end of the print I got a message on that I needed to reboot the machine, so I turned it off and back on again. The connection issue came up again and it took a significant amount of time to connect. It started the fans, then after a short amount of time where it didn’t connect it went into standby mode, and then after 15 or so minutes in standby mode, I pushed the button once and it started back up and connected. I was then able to run a print with no issues. Later I turned it off and came back to it, and it went through that exact same process, but it was able to connect in ~7 minutes rather than in 20+. I will make sure to turn the glowforge on tomorrow at 5pm CT, (10pm UTC) in case you need to look at it actively.

1 Like

Just started up the glowforge again this morning - it connected instantly just as it was doing prior to the update. Seems like the connection issues have been solved. Thanks!

1 Like

Hello again, and I’m sorry for the delay in getting back to you. I extracted the logs from those recent Glowforge connections, It looks like the update was able to apply successfully - your unit is up-to-date and appears to be running well! Thanks again for your patience, and for providing such helpful information to help us pinpoint the problem.

If you run into any other trouble, please let us know! We’re here to help!

1 Like