Glowforge Customer Service

Customer service is no. Existent at this point! My glowforge has been down 2 month, it isn’t even a year old and nobody will even respond to my emails! Please I already missed out on the Christmas season and I’m at my limits with this! Has anyone had to take legal action against glowforge?

They did get in touch with you by email back in November. Did you respond to those?

Yes I did, I sent them multiple pictures, I got a new black cable and it didn’t fix the problem. Fret that they just stopped responding. One person asked me for pictures of the cables to make sure it was installed correctly, I sent them and then nothing for a week; the next response was that I didn’t have the clips closed? Well duh they asked me to take pictures of the cable connection. So I sent new pictures and nothing… until I just posted her and finally they emailed me back, I kid you not in minutes. Guess what they said, looks like you are offline… well that is because it hasn’t been started in weeks because it doesn’t work and the customer service has chosen to ignore me rather than help me. The lady said, maybe it’s your wifi? I have been using this thing since May with no issues with my wifi?

Sorry to hear but to be truthful, your wifi could be receiving interference from a new source that wasn’t there previously. I t may not even be interference from your house but from a neighbor. If you search around on here there are some things you can try such as using your phone as a hotspot or dedicating a channel on your router to only the glowforge.


Have you looked at your little circuit board that the middle of that cable attaches too? Mine is black so that’s why the cable didn’t fix mine. I put my machine back in the box lol

These are the most recent pictures I have, this is the error I am still getting. I even tried resetting my internet and nothing. The machine works, the lights are on but the laser head and arm do not move at all.

I remember I started to have a bad connection and machines “offline” status. So I moved the router as close as I could to the machine and reconnected to wifi. After that no issues.

I had the same issue few weeks ago, when I got a cable and changed it I fixed the problem in seconds.

If nothing help maybe try to order another cable and change it again?
Before purchasing a cable try to reconnect to the wifi, but bring the router as close as possible to the machine.

I hope it helps.

Unfortunately nothing has worked, the wifi router is already right next to my machine. The machine powers on but the laser head and arm do not move. The forum seems like the only way I am receiving help. After not having it running, them telling me it’s the black cable, replacing it and it doing the same thing customer service just up and vanished. I did get an email from Glowforge directly after posting this thread but it just says my machine is offline and to check my internet? I did all of that, I even unhooked my router from the ethernet let it reconnect and everything is exactly the same. I use my internet daily I work a 9-5 job from home I have never had an issues. The only issue I am currently having is nobody wants to respond when I email them.

At this point I don’t want a refurbished machine but if that is what I need then I wish they would just tell me instead of telling me try this and then ghosting me!

Have you tried using your phone as a hot spot? That will 100% rule out or confirm you have issues with the wifi. Just because other items have no problem is not a guarantee the GF is receiving the signal. There could be something interfering that just makes the signal to the GF unstable enough to throw these failures. You have to prove one way or the other and that is a pretty simple way to do it.

1 Like

Hey Nicki,

I’m sad to read that you are not getting the level of support deserved for this issue. As @beerfaced mentioned it may be worth trying to connect with the phone hot spot to see if we can establish a link. Depending on how that works out we may have to set up a quick follow-up in the email to connect further on eliminating this issue for you. If the phone hot spot test is successful it may be a configuration on your network we will need to evaluate together.

Hi @nickiboyle. It looks like we were able to get a response back earlier this morning through your email thread to help resolve this. To avoid any potential confusion with multiple open threads, I’m going to close out this Community thread. We’ll look forward to your email response. Thank you!