Glowforge cutting things 1 mm larger than my SVG file

Hey all, I’m pretty new, so thanks in advance for any suggestions.

I’m creating patterns in inkscape, and I have the “geometric bounding box” option turned on.

I manually enter the width of my design (a watch strap, in this case) to 20 mm. However, after the glowforge cuts it, it measures about 21mm in width. Everything seems to be about 1 mm too wide.

I am using non-standard material (leather), and I am holding it down flat with magnets. The cuts seems to appear exactly where they are supposed to according to the camera, so the placement isn’t an issue. I’m also using a leather weight gauge to get as accurate a measurement of the thickness of the material as possible. So I’m pretty confident I have the thickness entered correctly. The only problem seems to be that my SVG file says 20 mm, and when I measure the cut piece, it is 21 mm.

I tested my SVG file with the proofgrade leather they sent, and I still saw the same issue. Still 21 mm instead of 20. So that seems like that would rule out it being any cutting settings entered wrongly.

Any suggestions? And according to the tech specs, it seems like there is supposed to be a .025 mm tolerance (which would be amazing).

Thanks so much!

Wish I could give you a good answer but on my phone and sitting in a brewery so a little less than precise in my memory. Inkscape has a setting in the preferences for bounding box. One is geometric?, I can’t remember the other. Has to do with whether it adds the line thickness in the sizes. Select the other setting than what you have.


Oh I read your post closer. I see that you have thought about that?

Thank you for replying even though you’re out for a drink! :joy:

And yeah, I have geometric bounding box selected. “Visual bounding box” is the one that includes the stroke size in the width!

It would help to attach the file you’re having trouble with.

Everything as far as material thickness settings, etc will not effect the actual size of the asset in the design.


So when I open in Inkscape it warns me that the file was created in an older version of Inkscape which was 90dpi and it needs to convert to the latest which is 96dpi. In doing so the band shows as 20.3mm. When I open the file in Illustrator, it’s 25mm.


Hmmmm, that is interesting. I did actually open and change things in a newer version of inkscape on a different computer as well, and I also got that dialogue. I selected that it was a file meant for cutting a physical product (or whatever the option was). I suppose there is a good chance this sort of thing has something to do with it!
Thank you for taking the time to open the file and look! I really appreciate it!

Now that I think about it, I am even more confused. All of the files I’ve tried have ORIGINATED from an old version of inkscape (in that, that’s where I first created them). Some of them I opened with a newer version, altered, and uploaded to glowforge from there. So, one of the most recent tests I’ve tried was converted to the new inkscape, and I’m looking at it now and it’s still set to 20 mm. I wonder if the issue is coming from the fact that they were either made in old inkscape and uploaded directly, or converted then uploaded.

I suppose this calls for a couple tests tomorrow from different versions of the program!

You might as well add the stitching holes while your at it. The glowforge does a great job of it.

Inkscape leaves a ton of old code in files. I think what I would do is create a new Inkscape document that is 20”w X 12”h, copy and paste the elements over, and then save as a Plain SVG (not Inkscape SVG).


Thanks for letting us know about this, @leroselle. And thanks to everyone who’s been helping in this thread. @jbmanning5 makes a particularly helpful observation, that saving as an “Inkscape SVG” means the file will contain a good deal of unnecessary data, especially if you’ve converted from a legacy file. I’d be interested to see whether copying the design contents into a new 20" x 12" document and saving as a “Plain SVG” helps. Defining the dimensions of the document is helpful to make sure the design scale is accurate when you open it in the Glowforge app. Could you please try this out and let me know what happens?

Thank you @jbmanning5 and @vee! What you suggested seems to have worked. It must’ve been something to do with the old version of inkscape or saving in an inkscape SVG.

Yesterday before your replies, I also did a lot of messing around/testing. I was able to open up my file in adobe illustrator. Illustrator read the file as like 5-6 mm larger than what the sizes were set to in inkscape, but everything was still proportional. So I manually typed in the correct length and width in illustrator, and saved it and uploaded it to glowforge. That also worked!

Thanks so much for your help. I’m so excited!

Attached is a picture of the huge difference between the way glowforge was reading the file, and the actual size the piece was supposed to be.


I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!