Glowforge down? "The design has failed to load"

I keep getting a “Design has failed to load” error. This is on new files, and existing ones. I have tried in 2 different browsers. No luck. I can’t get to cutting the thing I need to cut. Anyone else seeing this?

No, I am not getting this error. Have you tried opening the Gift of Good Measure just to rule out that it is a file issue?


Mine worked fine today, I believe it’s a local problem.


I just want to say, I absolutely hate how that has become the “default” test pattern.

It didn’t “become” the default test pattern, it has always been the test file.


I didn’t try that file specifically, but other files that I’ve printed with that are still in the UI, and other Glowforge premium files.

I just opened one of the most complex files I have in my usual browser, opened in seconds.

1 Like

If you’ve not had any success yet, do try the gift of good measure file…that is the specific file that support uses to diagnose any problems you might be having.


The gift of good measure has the same issue. Won’t load. I have tried multiple browsers, killing the browser and restarting, no luck.

Have you also tried resetting the modem/router/network? This sounds like a communication problem and however unlikely it may seem, 99.99% chance it is on your end somewhere. Any new electronic devices in the house or a change in location of something electronic. I had a similar issue and it was my AppleTV.

Not if it’s a design already on their dashboard, and that was the GoGM. There’s no passing of info about the design to the workspace that requires your broadband connection until it’s time to show the display.

I would suggest using a smartphone just to see if it works there - not to suggest you should just use it from now on, just as a check. Then send this info to support.

Thank you, I stand corrected. I was thinking that the designs were always uploaded and “rendered in the cloud” before each print.

OK. So I did a check as you suggested, and the iPhone and iPad versions of the site work fine. I tried clearing cache on the browser on my Mac and no luck. Heck, I even did a full restart of the computer just to try. So, you are right @eflyguy - it’s on my end, but only on my iMac. Not sure what other tips people may have to test why my one computer is failing to work with the UI. Would love other suggestions.

I’m on mac as well (as are many others) so I can’t think what else to check if this happens on multiple browsers. The workspace is just a rendering of the bed and design but it’s all in the cloud.

I’d ask about plugins and such but if it’s on multiple browsers that wouldn’t be the issue (and I run multiple track/ad blocking plugins and local security).

I’m at a loss, sorry.

1 Like

OK… thanks for your responses. You led me down the path, Logically you are right that browsers should rule out issues . The trouble is, I was using the Matter plug in on both Chrome and Safari. Your comment made me think about the most recent changes I have made. That was the ONE thing that came to mind . I disabled that plugin… and BAM… Things work again. (shakes fist in the air).

Thanks for the help! Back up and running



1 Like

Oh, man, IKR? My best success with troubleshooting an issue is “OK, what was the last thing I touched?”


Indeed. Best place to start troubleshooting is where a human has been involved :stuck_out_tongue_closed_eyes:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.