Glowforge going through motions but no laser

I will start by saying that I have reached out to GF about this issue and I have received an “Auto response” with steps to troubleshoot my issue. I have taken every step but my machine is still not working properly.

My issue:
Last week I sent a file to the GF machine and everything was cutting fine and about 3/4 through the cut the laser stopped cutting and the machine continued to go through the motions as if it was still cutting. I let it finish, opened the lid, put a new piece of material in, closed the lid and tried again. Again, the machine went through the motions with no laser from the start.

I know that GF is still a fairly new company and their customer service/tech dept is limited in their resources but the only response from GF I received via email was almost a week ago and I am concerned that it might have gotten lost in the shuffle.

I depend on the machine as do most of you in this community. Im just at a standstill at this point and would love to get back up and running as soon as possible.

1 Like

If it quit mid-print, it’s almost certainly a power supply or laser tube issue and will have to be sent in for repair/replacement.

Support will take a while to respond to your emails, as they don’t have a warehouse full of machines waiting to be shipped out. They will need to get an estimate of when a machine will be available from the outsourcer that assembles/refurbishes them. Could be a couple of weeks or more, hopefully less.


Double checking that you responded to the auto-response letting them know this, and including any picture or information that they requested?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.