Glowforge has no power

I have tried it all, but mid cut my forge shut off and now has no power. I have tried a different outlet, different black cord. Everything works in all the outlets other than the Glowforge. Not sure what the problem is. I have a basic.

1 Like

It’s possible your power supply has failed, which is something only a staffer can help with :frowning: I’d double check that all cables inside the machine are fully connecting/nothing is broken - and if you find anything questionable post pics of it, but otherwise you’ll need to wait for a staff member who will probably set up a repair invoice for you.


Hi @tuttle4 - I’m sorry to hear your printer is no longer powering on.

If it’s not waking up with known good outlets and multiple power cables it sounds like this is a problem with the printer’s power supply, in which case sadly we’ll need to replace your printer to get you back up and running.

I’m going to reach out to you via email with some next steps for what that would look like, but I’ll leave this topic open until I know you’ve received my email so that we can make sure you’re taken care of.

1 Like

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email