Glowforge making bumpy jagged prints

My glowforge has been having trouble moving to the right and completing detailed prints. It either stops print or they come out like the picture- in the wrong spot looking totally messed up. It seems like its skipping.

  • I have checked my right tension pulley and it is not broken, the metal part inside the pulley is able to rotate
  • The belt is in good shape
  • Nothing on carriage plate is broken

Im stumped, please help!

Check the carriage plate WHEELS very carefully for cracks or chips?


With the machine off, gently move the printhead left and right. Does it move all of the way to the right and back smoothly? Have you ever been able to cut things successfully - is this new behavior? Remove the tray and put a mirror on the floor of Glowforge so that you can see the belt as you move the printhead back and forth. Is the belt twisted? Are the teeth facing in?


I’ve checked them carefully. Not even a tiny chip or crack.

Yes, it moves left and right smoothly when I manually do it, the pulley rotates with the belt. No twist in belt. The teeth are facing in. About 1 out of 6 prints come out okay, so its really not functional. It cant print more than one design at a time without it skipping and printing incorrectly.

Thank y’all so much for trying to help I really appreciate it!

Can you print the Gift of Good Measure on typing paper and provide a photo of the results?

1 Like

It would not print. It began to move down and to the right. It began skipping then stopped the print and gave me the “unable to complete print” message.

Have you been in contact with Glowforge support?


Yes i’ve been going back and forth with them for a week. i’m just deperate at this point since I use my GF for business. They believed it was my tension pulley. I purchased a new one and replaced it- the problem did get better for a while maybe 20 or so prints then the issue started happening again. Jagged prints and “unable to complete print message”

Have you been able to get this error to occur with the Gift of Good Measure (a :glowforge: provided design)? Even if you have to run it 6 times, pictures of that, and the time you ran it, would give support the ability to check the logs against a known-good design.

1 Like

I was able to run Gift of Good Measure with the error occurring. It actually finished the print and gave me the error after, the majority of the time my prints cant even start.

Support has never even asked for my logs and we have been going back and forth for over a week. All they have done is told me to buy a new pulley and then buy a new belt. Which neither have fixed my issue but hey they’ve gotten me to spend more money!! I use my GF for business so it working properly is a must. Any advise will help- thank you!

Ah, if they’ve moved on to replacing parts than it’s because they had already looked at your logs and confirmed it was a physical issue.

This will seem annoying and repetitive - but my next suggestion would to pull the carriage plate off, and take a picture of the setup.
Then remove the belts and take pictures along the lengths, both horizontal and vertical.
Then the wheels both on the carriage plate and the horizontal and vertical bars.
There’s something physically causing this, and as it’s intermittent it’s unlikely to be easy to spot!

1 Like

Ok thank you so much for explaining that to me! From what I can see there are no cracks in the pulleys on the left and right side rail. I was afraid to remove those belts because I have a hard time getting the tension high enough. I have attached photos. Thank you SO much!

Another example of a print messing up. I wish I was able to tell where the issue is coming from based on the error occurring.

Are you using PG settings on the acrylic? I wonder if figuring out a lower power, slower setting might help. I agree I don’t see anything on your parts, but wow does your result seem like it’s driving over rough ground!

Do you have the capability of recording it while it’s cutting, with sound? Maybe one of us could see/hear a clue!

What did Support say in their last contact?

ah! Thank you a million for looking at the pics. Ive been using PG setting on my acrylic for about a year with no issues.

At first they seem to think i’m not putting the tension belt tight enough -myself and my 200lb partner have both tried many many times to push the right pulley as far to the right as we can. The last thing with support was to change the belt out with a new one. I did that and just waiting for a response. I’ll attach a short video of the tension so you can see how it looks.


Attempting to print:

Tension looks fine to me.
That thunk when it’s trying to print is…impressive :frowning:

When you first turn on the machine it also moves the head to center to calibrate - does it complete that and only have an issue when you hit print, or is it unable to calibrate as well?

Yea it makes some crazy noises! Okay i’m glad you agree with the tension.

Its weird but sometimes it can calibrate and start the print and then the error occurs. Other times its like in the video where it messes up as soon as it goes to center. As of right now its completely out of commission and can’t even complete one print correctly. I checked all my bearings on my carriage plate, nothing. I’ve cleaned all the rails to make sure nothing is physically in the way… What are your thoughts?

*This is not something I’ve ever tried, but I’m grasping at straws here! :crossed_fingers:

What happens if you remove the carriage plate entirely and then try to start it up? You’d need to take the head off and tape it (or something) to the bar so you can leave the ribbon attached.
It’s not going to succeed, but I’m curious if it moves or grinds. If not then the issue is in there somewhere. If it still grinds I’m wondering if it’s something broken/breaking in the motor itself.

1 Like