Glowforge not centering at startup

I’ve read through other threads and an not having any luck. My wife was cutting something from leather and the leather was sticking up on one end which caused the leather to be drug about the bed. That was yesterday.

Today whenever we start the printer the warmup cycle begins and then fails when the head would normally begin centering. The app says centering, the settings report scanning.

The WiFi is, should be, nearly 90%, excellent home coverage. When off, the arm moves freely and does not stick. Connections seem well. Freshly cleaned lenses and mirror. Have left it sit for upwards of twenty minutes in case it was updating. I can hear the arm shift as if it tried to move

Uploading video to YouTube to share. Any help is greatly appreciated, wife is a bit beside herself.

If you haven’t already tried this, remove all material from the bed, position the printhead directly under the lid camera and then turn the Glowforge back on.


@dklgood I just tried this I can see the print head “jerk” towards the right, but then it stops. Bad stepper motor maybe?

Something might have gotten wonky when the printhead was dragging the leather about.

1 Like

I seriously doubt that, Not that it isn’t possible, just that steppers are so simple they are not known as a point of failure. More likely bad communication. There is robust communication between the machine and server at startup. The machine takes a picture of the bed and sends that to the server that tries to locate the head. The server sends a motion order to the machine to move the head. This back-and-forth continues until the server sees the logo on the head under the camera. That completes the mapping of the bed so the server knows the limits. Drop a packet in that conversation and the machine balks.

Since the UI is browser-based, that introduces a bunch of variables, a few concern the machine like the possibility of a stepper problem as you suspected. The black cable that connects the camera and lid sensors has been known to fail, and the inability to take a picture prevents calibration when it is turned on. It is speculated that opening the lid all the way flexes the cable too much. I and several others have had to replace that cable.
Wifi interference can cause it, and a bag of possibilities comes with that. A good way to eliminate the browser and wifi possibility is to connect to your phone’s hotspot. That would help to determine if it’s a browser problem or the machine.

We understand the feeling when your machine exhibits abhorrent behavior. :grimacing:


@PrintToLaser my wife says there was a pop-up about not being able to take a picture. How do I troubleshoot this mess?

If the camera lens is clean, I think the next step would be to replace that black lid cable. They sell them in the store.
Be sure the machine is off while that is performed. Instructions to do that are in the support section.


The fact that the machine “focuses” (the clicking noises from the print head shortly after you power it on) means it’s online and connected to Glowforge’s cloud servers. Seconding that the next thing to investigate is that black lid cable that carries the data to and from the lid camera, which is needed for centering/homing to work.

1 Like

Got the cable today (no thanks to the hurricane) - that was the issue. Thanks everyone.


Glad you’re up and running again Bob. :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.