Glowforge not connecting to WiFi - lagging Tech Support

I just spent 2 hours running multiple configurations on my router and the only way I am able to use my new Glowforge is to bypass my router (mesh network, multi-band, WPA security, 1 gig pipe , etc.) and instead use my mobile phone as a hotspot.

I also missed that techincal support is only by email and takes up to 24 hours when I purchased my new device this week.

If and when technical support gets to this thread, I would appreciate a real-time communication channel to resolve this issue. It is unseemly to me to have a $6000 piece of equipment, built in 2020 that is incapable of working with WiFi network protocols that have existed for over 20 years.

ceteris paribus
things I wish I’d known

1 Like

I have a mesh WiFi network with WPA2 and multi-band and my Glowforge works perfectly. I have never had a network issue with it in the entire time I have owned it, which is going on two years now.

I hope you get the problem resolved.


I run mine on an Orbi mesh. Create a dedicated 2.4GHz channel just for the GF. It solved my problem.


So, I ended up setting up a 2.4GHz network on my ISP’s router that is separate from my home router. It took a bit of “convincing” to get the ISP router to cooperate, but I now have a dedicated 2.4GHz WiFi network with the SSID hidden.

Great work around! Thank you for leading me down this path. It’s not ideal, but it is better than using my phone…lol

I’ll see if tech support has any suggestions on if I can get this to work with my ASUS router.


I’m glad you got it going. Feel free to ask questions of all of us anytime. Thats what this forum is all about.


Hello @cmentmixer! I see you already emailed us about this issue and we’ve responded to you there, so I’m going to close this topic.