Glowforge not moving on start up

The glowforge is showing offline when I connect through the app. I have shut both it and the computer down so that they would reset. The glowforge does not do its calibration dance when it starts up at all. Worked fine yesterday during the day and night. The next day sothing would happen. Tried to reset up the glowforge and it shows up with an error message. Any ideas would be great.

What is the error message?

For what it’s worth, most of the time when the symptom is that it doesn’t do its homing thing when you turn it on, the issue is that it can’t connect to the Glowforge servers. And that usually means it’s not getting on your WiFi reliably. This can be hard to troubleshoot because it’s basically invisible, and just because your laptop or phone connects in the same area doesn’t mean the Glowforge will, owing to different chips and antennas.

Sometimes it can help to reboot your router or try moving things around.

There are other possibilities, like a bad lid camera cable, but if it were my machine, I’d be trying WiFi troubleshooting.

1 Like

I’m sorry that you are running into trouble.

@chris1 Thank you for that suggestion. That is always a great place to start when going through issues like this.

After extracting the logs of your Glowforge, I did notice your Glowforge was able to connect successfully to your network, but it may be having trouble maintaining a stable connection. When this is the case, you won’t need to go through Wi-Fi setup again, but you may see an “Offline” message.

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

If you’re still having trouble, there’s a test you can try that will help us narrow down the problem. If possible, could you please create a Wi-Fi hotspot with a cell phone and use that network to connect your Glowforge to Wi-Fi? This is a good way to rule out signal interference, since you can set your phone right on top of your Glowforge!

You can find instructions online to help you create a Wi-Fi hotspot using a cell phone. Make sure that you set it up to be a 2.4 GHz hotspot, since that is the frequency your Glowforge uses.

Once the Wi-Fi hotspot is broadcasting, you can connect to it by following these steps:

  1. Turn on your Glowforge.
  2. Wait 30 seconds. Then hold down the button for ten seconds until it glows teal.
  3. Navigate to setup.glowforge.com and follow the instructions on-screen. When prompted to connect your Glowforge to Wi-Fi, choose the hotspot you created.
  4. Once Wi-Fi setup is complete, go to app.glowforge.com and try a few prints.

Let us know how it goes.

I HAVE HAD THE INTERNET PPL COME TO MY HOUSE. MY NETWORK STRENGTH IS 100%. I HAVE TRIED CONNECTING TO MY HOT SPOT, I HAVE TRIED CONNECTING TO MY NEIGHBORS WIFI AND MY OWN WIFI AND THE MACHING IS STILL GIVING ME THIS ERROR WHEN I TRY TO CONNECT TO ANY WIFI. I HAVE DONE EVERY STEP MULTIPLE TIMES AND I NEED SOME HELP. I HAVE WORK ORDERS I NEED TO FINISH.

Stop yelling.
Radio signals aren’t measured in percent, but I’m guessing you think your signal strength is adequate. So let’s assume that’s the case.
When you click “Restart Setup” what happens? Feel free to screenshot and document each step for us so we can tell you if what you’re seeing is correct.
Are you sure you’re attempting to connect to 2.4 GHz signals?
Is your hot spot on your phone or a specific hot spot device? Some hot spots generate their signal based on cell towers, some based on the wireless they’re connected to already. So it’s possible you’re not passing a 2.4 GHz signal to your Glowforge.
Also, ask your neighbor what frequency they’re broadcasting on.
But ultimately you’ll probably want this to function with your own static wifi signal. So take a look there first. What 2.4 GHz channel are you broadcasting on? If it’s set to some sort of automatic channel, try specifically using 1, 6, or 11. Try each and see what happens.

The GF won’t even see 5GHz wifi, so it’s impossible to select it during setup.

Sorry, yes… But some routers use 1 SSID and will auto-switch between frequencies as it sees fit. My router, for example, would do that if I enabled the feature. But I’ve chosen not to until I know I can force it to always let the Glowforge use 2.4 GHz. It’s a great idea, really. Supposedly it’ll sense when a device is getting out of range of the 5 GHz signal and seamlessly hand it over to 2.4 GHz. And then when it senses it can get a solid 5 GHz signal it’ll switch it back. Great for everything… except, I suspect, a Glowforge.

1 Like

A thing that I learned from a friend who had to troubleshoot WiFi problems in great detail for his very interesting robotics job: it’s almost always the client. And also that WiFi is extraordinarily complicated. In practice, this means that there are dozens of standards and thousands of pages which may unimplemented or implemented incorrectly on any given device. The new self-watering plant you bought on Kickstarter with a 67 cent WiFi chip from AliExpress is unlikely to get everything right, and all your base station can really do about it is have the firmware hard code a bunch of known bugs and workarounds for bad clients.

This is why it’s so frustrating to troubleshoot Glowforge WiFi problems. But my iPad is right next to the Glowforge and works fine!, you might think. But Apple spends a fortune making their WiFi robust and implementing all kinds of extensions. I have an “enterprise” mesh system in my house with multiple four-figure base stations. Right next to me is a device that I can’t get online because it has a tiny antenna and instead of connecting to the station with the strong signal in this same room, it connects to the one three floors away that’s too weak to work. I have e-mailed the creator back and forth and we finally worked out that he’s using a chip whose default behavior when it sees more than one access point is to sort by MAC address and connect to the one that comes alphabetically first. He’d have to write a bunch of extra code to scan and pick the strongest signal.

It’s really a ridiculous situation.

3 Likes

Thanks for the great information in this thread, everyone. Based on the research we’ve done in an existing email thread, signs seem to be pointing to port 443 being inadvertently blocked in network firewall settings. However, we’re happy to keep troubleshooting. Since you already emailed us about this and we’re working on it there, so I’m going to close this topic.