Glowforge not printing/cutting to the correct size

Ok, I have a problem with my Glowforge printing to scale. I don’t know exactly when this started to happen, but I just noticed it today; it must be recently. First, let me say I have had my machine for over a year and had one small issue which support was able to solve in less than a day. Today I was trying to print a part for a scale ship model I am building and one of the ribs was supposed to be 10-7/8” long but when I cut it out it came out 11-1/4” long. It’s the same file I had printed before out of cardboard as a mock-up and the mock-up printed perfectly to scale, but this time I was cutting it out of the final material and it was over-sized. First, I thought maybe the file was corrupt, so I did a few simple tests and everything I tried came out the wrong scale. Created a simple file of rectangles ¼” x 1”, 2”, 3”, 4” up to 11” and all where larger by the small ratio, roughly 103.5%. I did a trough cleaning about 5 cutting hours ago , but cleaned all 4 lenses again, check the crumb tray for debris etc… The machine has been in the same place since I got it, so nothing physically has changed since day one.

Here is what I have done so far:
Machine has recently been cleaned
Lenses cleaned (4), before this test
Crumb tray checked for debris
Checked the file, tried new files, old files all get the same result
Checked the settings to make sure I had entered the correct material thickness
Restarted the machine many times
Restarted the computer, and tried a different computer
Restarted the router
Logged out of the Glowforge App and signed back in again
No electrical surges, brownouts or power outages
Machine hasn’t been jarred, or moved

I then decided to print the Glowforge Ruler on medium draftboard and compare it with the one I printed when I first got the machine. Everything appears on the screen correctly but cuts larger. The machine recognizes the draftboard and sets all the default settings for draftboard and cuts beautifully except for the scale.

Figured support would want me to print the Gift of Good Measure so I tried that. Same result, out of scale. These cuts were made with the draftboard directly under the focusing camera, center of the bed.

Attached in the zip file are screen shots of the Glowforge Rulers, and the Gift of Good Measure along side my set of calibers to show the problem.

Screenshot1 – Gift of Good Measure highlighted before cutting showing the size on the ruler bars
Screenshot2 – Gift of Good Measure not highlighted before cutting
Screenshot3 – Gift of Good Measure after cutting
Screenshot4 – Gift of Good Measure close-up
Screenshot5 – Glowforge Ruler highlighted before cutting showing the size on the ruler bars
Screenshot6 – Glowforge Ruler not highlighted before cutting
Screenshot7 – Glowforge Ruler after cutting
Screenshot8 – Glowforge Ruler close-up
Photo-8037 – Glowforge Rulers, with calibers showing size, upside ruler is the one I cut when I first got the machine and the right side up one was printed today showing the side by side scale.
Photo-8040 – Gift of Good Measure with calibers showing size.

Everything shows up in the app perfectly, that is the correct scale, but cuts over-sized.

I primarily use Inkscape, Windows 10, Chrome, all the latest versions.

The test prints of the Gift of Good Measure were at 9:10PM (3:57 of print/cut time) and the Glowforge Ruler at 9:26PM (5:10 of print/cut time) Saturday, May 4th, Central Standard Time.

Thanks for any assistance. I hope it’s something support can correctly remotely as my warranty has expired.Glowforge (596.2 KB)


That is weird since it is in the print and not in the GFUI nor design software.

I hope it is one of those situations where they can fix a setting that got wonked from the mother ship.


An update, I keep good records of when, what I cut, and what the settings were. On March 28 I cut a number of things and the ones I was able to measure all cut the same size as the drawing/svg files. I measured the things I cut on April 18 and ALL of those items are NOT the same size as the drawings and everything since then is cut to the wrong size. So, sometime between March 28 and April 18 my machine decided to go bonkers. I didn’t notice until yesterday because everything I cut didn’t have to fit together and since everything is off by only 3.5%+/- it wasn’t noticeable. Now that I am cutting things that have to fit together with previously cut pieces i have hit a brick wall.
I hope this helps support narrow down when the problem started to occur and what could have caused it.
Thanks and waiting for any suggestions.

Another update, I rotated the image 90 degrees so the long axis of the image was in the X axis (up and down) and it printed to the correct dimension. If I orientate it with the long axis of the image in the Y axis (side to side) it prints everything 3.5% larger than drawn. Could it be a problem with the Y axis stepper motor?

I am having a similar problem to this. Was it ever solved? I see no answers here that aren’t from the OP.

I have not heard back from support yet.
I apologize for forgetting my high school math. I got my X and Y axis wrong. The machine is NOT printing correctly in the X axis (right to left) but seems to be printing in the Y axis (up and down) correctly.
I ran another test today and the problem remains.

I’m so sorry for the delay replying.

Thank you so much for all the details and such a thorough investigation.

I’m looking into it now. As soon as I have more information I’ll update this thread.

I was hoping to hear something by now. Would love to get back to cutting some cut to fit pieces. I would also love to test the new camera calibration feature but I’m afraid if I try to score the test pattern the head will bang into the side walls since it enlarges everything in that direction. Any updates coming soon?

Glowforge Support Team
I have fixed the problem. After reading another users problem it dawned on me that this problem started occurring after I had I cleaned the assist fan so I decided to take things apart again and I noticed that the belt had a twist in it. I reassembled everything again paying close attention to get the belt on right. I check everything with a mirror to verify things we on straight and everything is printing to scale again.
@srciaran you might want to use a mirror to check that the belt is not twisted.


Thanks so much for letting us know about that. I’m glad you were able to resolve it, and I’ve passed these details along to the team so we can be sure to check for this in the future. If you run into any other trouble, please start a new topic. Thanks again.