Glowforge Offline; Nothing in support files fix

I just received my warranty replacement Glowforge, and I cannot get it to connect online. The first Glowforge I had was able to connect and run, so I know my other hardware (computer/router/modem/ect) are capable of working with a GF if they are running properly. Not saying the issue is for sure the GF, just that I’ve been able to connect other GF’s using my current set up.

Anyways, the completes flawlessly. I get the “Setup Complete” screen with raining confetti and everything. However, when I try to run the app, I get the “Your Glowforge is offline.” message.

I’ve tried everything in the support files including restarting ALL the devices multiple times, moving router closer (it’s currently in the same room and elevated), and turning off all other electronics.

Additionally, I’ve reran setup multiple times (which always seems to complete perfectly) and tried a spare computer, which also complete set up fine, but still gave the “Offline” message.

Any other suggestions? I really wanted to get the GF up and running before Christmas so I could make some gifts, but this is already machine #2 so I’m getting a little worried :frowning:

One small thing to check: when you are in the app, have you picked the right GF from the dropdown in the upper right? The app will know about both your new and old GFs…


You sir, are the man. Thanks a bunch. We are up and running.


I’m glad you resolved it! I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!