Glowforge Offline Troubleshooting

I’m aware this is a popular topic, but the previous posts haven’t resolved my issue or the ultimate fix wasn’t posted.


  • Glowforge is appearing offline in app UI
  • Glowforge isn’t doing the full calibration dance upon startup


  1. My Glowforge was previously up / running / cutting / fully operational but has been idle for the past 2+ months. There is no major change to physical or WIFI setup I am aware of.

  2. I have tried all combinations of restart / reset for Glowforge / router / computer / browser.

  3. My Glowforge was previously successfully connected to my apartment WIFI. If I try to redo this setup procedure, I get an error. Hold Glowforge button until teal > Go to > Connect laptop to Glowforge WIFI > Find my apartment WIFI > Type Password > Get “Device Error! While trying to setup your Glowforge, it became no longer reachable or responded in an unexpected way. Please make sure you are connected to the Glowforge wifi network and click Restart Setup.” I am certain I have the password is correct which I have verified using my laptop by removing the network and re-entering.

  4. My WIFI router is ~10 feet away from the Glowforge. For troubleshooting, I also moved a WIFI repeater directly next to the Glowforge. Without repeater, internet speed is ~25 mbps. I do live in an urban apartment building with many nearby WIFIs, but again, the Glowforge was previously working fine.

  5. I have downloaded the Glowforge WIFI zipped file log while on my Glowforge WIFI via but I am not sure how to use / interpret these files, or if they are useful for my issue.

a. Should I be able to reconnect to my previously established WIFI or is the error in (3) normal? Is the error a me-problem or a Glowforge-problem? How do I verify this?
b. Are there any other hardware / software / factory resets I can do?

1 Like

You should be able to reconnect to the same WiFi without getting that error
Is there a chance you got a software “upgrade” that made it mode-switch and it’s ended up on a 5Mhz channel?
One of your neighbors could have added something that’s messing with it (which is frustrating, but does happen - let’s not go there yet!)
Those logs can be helpful to the staff, but yeah, they’re not designed to be readable.
Speed is less important that reliability. Quick blips that wouldn’t be noticed by TV/computer/etc. will seriously mess with the :glowforge: - can you do the test after " We’re not finished!" here: Displaying as "Calibrating", then reverting to "Offline"
If there’s serious blips that may give us an answer, if there aren’t it’ll be helpful to the staff person who eventually gets here.

Fingers crossed!


It’s not possible to connect to a 5GHz network, the GF won’t even see it.

It’s possible that there is interference from another network nearby. Most routers will give you the option to automatically switch to the best channel, based on them “surveying” the signals in the area. That would be the best place to start.

You can rule out any issue with the machine itself by setting up your mobile phone as a temporary hotspot and connecting the machine to that. If everything works as it should, then you can continue to focus on your wifi setup.


Today’s troubleshooting has been unsuccessful. I still cannot manage to connect to the original WIFI network, after resetting / renaming / reconfiguring / re-firmware-ing my router.

Results copied here.
50 packets transmitted, 50 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 38.295/38.674/40.946/0.390 ms

My router does have this option. I have tried it both on / off unsuccessfully.

I won’t be able to do this with my phone, but tomorrow I will attempt to move my Glowforge as physically close to the router as possible.

If it were purely a WIFI issue, shouldn’t I still be getting the full calibration sequence?

I won’t be able to do this with my phone, but tomorrow I will attempt to move my Glowforge as physically close to the router as possible.

It’s not always a matter of proximity/signal strength, but it’s worth a try.

If it were purely a WIFI issue, shouldn’t I still be getting the full calibration sequence?

No, it depends on the connection to the cloud.

I actually had to move mine farther from the router once… It was so odd. Turned out I had a 2.4ghz security cam that was close and seemed to be messing with the GF.


I had run for months fine when I first got mine, then had Offline issues (and new neighbors). Changing the Channel on my network settings to 9 helped for a while, (more neighbor changes–have apts around me) then to channel 11, and has been 18 months again without issue.

So “nothing has changed” maybe true within your home (as was with mine), but you can be affected by what others are doing, too. And as noted, make sure you have dedicated 2.4gHz for your GF. Not “band steering” (a thing Xfinity does by default now) or 5gHz, but dedicated 2.4gHz. You may have to call your provider to verify/change to dedicated bands, and you can set up 2 networks in your house, one for 2.4 for the GF, and a 5 for everything else…


Interesting, but I believe you are having a different problem.
I hold print button to broadcast GF WIFI = fine, see GF WIFI on my web browser = fine, in GF setup see my personal WIFI = fine, enter personal WIFI password and hit connect = get error.

Great suggestion. I have tried that to no avail, individually selecting channels 1~11 one at a time getting the same error for each.


Spitballing, but is there any chance you could create a hotspot with your phone? The next question of course is would that be a 2.4 ghz signal.

When I was first getting my GF setup I could not get it to work on our school network. The IT guy said the GF was the issue… I carefully packed it back up and took it to my house. It connected in 5 min to my home network… He still fought with me when I brought it back…

In the end the issue in my classroom was not his fault, but the 2.4ghz security cam I had near it. Do you have baby monitors, wifi garage doors, or wireless phones near it?

I am sure the questions get tiring, but it is hard to think of all the stuff it could be. I still wish there was a Ethernet port as well.


Until there is an alternate WiFi network available that it failed connect to and set up, it’s hard to say that it’s not a network issue. Thanks for being so detailed in all the steps and sticking with this to eliminate the possible issues. I hope you can get this resolved without a replacement unit.

I ended up boxing up my machine and moving it to a completely different building / WIFI / router / computer / etc. and have the same issue - I can see and connect to the Glowforge’s WIFI, but after entering the password for a personal 2.4 GHz WIFI network get an error and fail to connect.

This makes me conclude it must be something associated with my specific machine as opposed to network. I will pray to the Glowforge Support team gods unless there is any kind of additional machine-level hardware / software / firmware reset I can perform.

1 Like

@mattvan.dyke I just followed up with your email, I am sorry for our delay. After research we’ve found that this issue is related to specifically to printer. Please follow up directly to our email.