Glowforge pro does not turn on at all

I tried printing something and seems like my machine is dead :frowning:

1 Like

I’m sure someone will be here soon to try to help you, but you’ll need to post more specific information before they are able to see what the issue might be.

1 Like

Well it doesn’t turn on at all. Outlets work perfectly fine.

its completely dead. Won’t turn on at all now. Don’t know what’s causing this issue if I’ve used it earlier and it wasn’t giving me any problems till now when I tried doing a print today.

Is the staple on the back above the power strip fully pushed in?



Yes it is :frowning:

1 Like

As long as that is positively established - Make sure the power cord hasn’t loosened where it plugs into the machine, and the power switch next to it is “On”. Gotta start troubleshooting somewhere, and that would be first.

1 Like

The “staple” has no effect on power.

It simply disables the machine - like opening the lid, except if it’s in-use, the head will not retract. The machine just freezes and has to be power-cycled to reboot…

1 Like

Hi @the_creativemermaid. I received your updated results of the checks in your opened email support request. I just sent a response through email with next steps to address this. To avoid any confusion or miscommunication, I’ll go ahead and close this thread so we can continue the discussion through email. Thank you!