Glowforge Pro won't turn on

EDIT: It was a problem with the outlet. Not sure what happened with the alignment though. It fixed it’s self (mostly) once I got the glowforge back running.

I just received my glowforge pro less than a month ago and I was trying out the pass through for the first time. After 4 attempts to try to get it to align correctly, I went to turn it off to see if I turn it off and then back on, if it will reset it’s self and align correctly. After I waited a minute, I tried to turn it back on and it would not power on or anything. So, I unplugged the cord to the glowforge and put it back in, still nothing. I unplugged it from the wall and pushed reset/test on the outlet and plugged it back in, and still nothing.

Anyone have any suggestions? I have contacted support, but they said it could be up to 3 day for a response back.

You can try a different outlet, and you can try a different cord (it’s a standard PC/monitor cord, so if you’ve ever had a desktop computer or monitor, you probably have another cord to try). If neither of those works, it’s probably the power supply that went, which means a trip back to Glowforge Inc for a warranty replacement.


Did you check the one on the back of the Glowforge above the switch?


There is no reset button on the back of the Glowforge.


my power not working ethier

What did support say?

At least from what I have been part of, I have recently encountered a few new machines that are having a bit of power troubles. Mainly things like their voltage reading being a bit higher then it should be for certain parts.

I assume glowforge is like the rest of the tech industry and we are having to sub out parts for the time being. It sucks when you have a solid board design and then some of the components are suddenly not available. I would hang in there though and just consider it part of life with owning technology. I wish I have more input I could give.


There is a button that will cut the power for however it works on the back of a pro. If you accidentally move it you would have the effect noted.

No it won’t.

There is no button. There is a safety interlock connector with a “staple” shaped pin. If you remove the pin, the machine still powers on. It just won’t operate.

If the machine is in use when the safety is triggered, the machine simply halts. Power stays on. The laser stops firing and the head no longer moves. You have to power down to reboot it.

If you connect a safety switch, it will break that connection and halt the machine.


I have only tried it once accidentally the first month I had it. I don’t remember the lights going on. It might be useful if you just want to try the lights.

Did you watch the video?

The machine powers on. Intake fans come on (you won’t hear the initial roar of the exhaust fan as I don’t have one).

1 Like

I would assume this means “on the outlet” not on the machine.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.