Glowforge Separating design into two layers

I have a very simple svg (included below) that is a polyline and a line. For some reason, Glowforge is separating these out into two layers. For efficiency, Id really like it to be one layer. From my research in this forum, it seems that glowforge separates layers based on color, but as you can see below, both the polyline and line have the same color. Does anyone know whats going on here?
sample

2 Likes

It’s usually how you have it set up in the artwork file. (And since layers has a very different meaning in design programs, you mean separate objects within the GFUI–you get two when you only want 1, correct?).

Have you tried to group them so they are one object within your file? This might make them appear as one item in the GFUI.

1 Like

What application are you using to create this? It doesn’t appear to be a valid SVG.

Just boolean add them together into one shape.

GF ignores groups. You have to combine the shapes.

It loads fine for me – maybe your download got corrupted?

See if this does the trick:

d50ed13e16898015a53e9ce51eaa7401173f5b67

I solved my own problem. It seems that glowforge separates layers based on color AND fill. My polyline had a fill of “none” but my line had no fill attribute because that doesnt make sense for a line, but when I added fill=“none” to my line, glowforge put them both onto the same layer. Problem solved. (Im creating my own SVG file with a computer program that I wrote)

6 Likes

Thanks for clarifying!

I’m so sorry to hear that you hit this snag, and I apologize for the delay in response.

I’m glad to hear that you were able to resolve the trouble you were experiencing. I’ll close this topic, but please do not hesitate to reach out to us directly at support@glowforge.com in the future.