Glowforge Service is still not right

So the laser focus is back to normal, However the “Preparing your print” is taking FOREVER. Im at 10 minutes so far and its still preparing, once its ready the laser works fine. Just making the post to say something is still wonky with the servers.

opens a ticket

Still an issue at 7am Eastern. Had same problem at 6pm yesterday but I tried again at 9:30pm and it was fine.

Chiming in here that I’m also having slow processing speeds. Usually takes about 30 seconds for this specific file to process from Print to Button Press. Now taking more like 3 minutes.

I was having the same problem about 30min ago. So frustrating! I wish we had an actual computer based software to avoid all this hassle!!!

Make sure you’ve cleared your cache and restarted your browser since the server issues. That’s important to remember whenever there’s an issue like the one yesterday.


Tried, doesnt fix the issue.

It’s a service issue again. Same here. They’ve already acknowledged it in another thread.

1 Like

Yea I just saw this. Geez this is getting a little crazy!

I wonder if it was caused by the Google Cloud issues?

1 Like

Thank you for letting us know about this. I’m so sorry that the trouble was continuing into today. We’ve implemented a fix that should take care of this issue for you. Could you please try printing again, and let me know if you’re still running into the same behavior?

1 Like

I see that you’ve responded on a new forum post, so I’ll close this thread and continue following up there. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.