Glowforge Specific Fusion 360 Training - Start of Live Webinar Series

fusion360
3d
training
cad
designsoftware

#122

It can be done, technically, but it’s not terribly intuitive.


#123

Not at all. That was just my own insecurities around being needy :slight_smile:


#124

Thanks again for doing these, Jason! Eagerly awaiting webinars 4 – 6. :sunglasses:


#125

I’ve received a lot of feedback requesting a deep dive into sketching.
So, I’m going for it.
I’m calling it part 0 because it is going to start off even more basic than any of the previous webinars.

When: TOMORROW Dec 8, 2017 3:30 PM Mountain Time (US and Canada)
Topic: Introduction to Fusion 360 for Glowforge Users - Part 0

Register in advance for this webinar:
https://autodesk.zoom.us/webinar/register/WN_vAJaQfwTSj6ORvhQNYKmRg
After registering, you will receive a confirmation email containing information about joining the webinar.


#126

Dangit! I registered but then noticed it is at a time I’m committed to something else. So I will have to watch the rerun.

Thanks Jason!


#127

The recording for Webinar #00 is now live at: https://youtu.be/3oJIlU4H1as

Cheers,
Jason


#128

You’re so generous with your time to put all of these together! It’s a bit unfortunate that all of that work is being undermined by the open-plan office making the audio borderline unlistenable. Maybe next time you can book a conference room or something? This is valuable outreach, they should really let you use a quiet space.


#129

Hey Jason, I had a question for you during today’s seminar, and I’m at a loss where to find this, so if you could just tell me how to get into the Settings area for F360 maybe I can find it…

Here’s what I’m seeing, and it’s done it before on other projects I attempted - when I use the Spline tool on a sketch to create a curved line, then export the sketch as a DXF and take it into Illustrator, instead of getting smooth Bezier style curves, it comes across as short joined segments. (And the Glowforge is accurate enough that they actually do print that way.)

Example:

This in F360:

Comes across this way when the DXF is opened in Illustrator:

If there is a place where I can turn that off, I’d like to find it. (Probably shouldn’t have interrupted the webinar for it…I was just wondering how do I find the Settings in F360? I’ve obviously got it set up for segments.)

It introduces a tremendous amount of excess nodes into the file on more complex curved builds, and we’re having to watch for that because of the buffer situation. And it imparts a non-smooth texture since the laser actually follows that path exactly.

Anywho…i want to fix that if i can. :slightly_smiling_face:
(many thanks!)


#130

Preferences is strangely buried in the upper right by clicking on your name.

No idea about the actual problem, hopefully Jason will have something.


#131

And I never would have found that! ROFL! Thanks! :smile:

(And now I’m going to have to act like a dummy and ask where to find that particular function, because I don’t see anything that might work in the preferences.)


#132

Ouch. He said exactly that today…


#133

I found this problem very distracting, and as sometimes happens, I couldn’t let go of it until I read the DXF specification and dissected the files to figure out what’s going on.

The simple answer is that the files produced by Fusion 360’s save-sketch-as-DXF contain something Illustrator doesn’t support: Fusion’s splines are of degree 5, and Illustrator only properly imports degree-3 splines.

Of course, when you unpack that, it gets a lot more complicated. In terms of the data, DXF files are (usually) just text, and they have a straightforward tagged format of a one line group code followed by one line of data. If you poke around, you’ll find:

0
SPLINE

and then somewhere below that:

71
5

71 is the code for degree. I have tried DXFs with degree-3 splines (which the “Save DXF for Laser Cutting” add-on produces) and they load nicely in Illustrator, but the degree-5 ones get treated as line segments.

Our friends at Autodesk may have some ideas for how to deal with this situation, but I’m pretty sure that explains why it’s happening.


#134

Well, that might be the temporary answer to the issue…I don’t want to ask the Fusion folks to rework their parameters for DXF export … got a link to the add-on for Windows?

(If it’s that Shaper Utilities thing, I’m still trying to get a Windows version of it - the link seems to be defaulting to a Mac version, and my computer inconveniently cratered before I could follow up.)


#135

I’m trying a bunch of potential workarounds. Here’s an expensive one: EXDXF-Pro. I just tried the trial version and it loaded my test DXF correctly.

EDIT: I’m going to amend that statement. I don’t believe it imports “correctly”, in a technical sense. It has an option called “Polyline Smoothing”, which simply causes it to import the same set of line segments, but it smooths out the corners between them. The end result looks pretty much the same, and in most cases may be practically indistinguishable, but technically it’s still throwing away some of the geometry and replacing it with an interpolation. It’s possible that in some fancy-dancy curves, it could produce a different result than the original.


#136

I think this is the one:
https://apps.autodesk.com/FUSION/en/Detail/Index?id=7634902334100976871&os=Win64&appLang=en

You’ll see it show up in the Sketch menu after it’s installed. It works a little bit differently, in that you don’t select a sketch, you select one face of a 3D body, and it will export the profile. (For most of the stuff I do, this is actually more convenient)


#137

install both the Shaper one and the one @chris1 pointed out. The one @chris1 pointed to exports a DXF and lets you tweak your kerf right in the plugin.

This one exports a SVG and can be very useful as well.

https://apps.autodesk.com/FUSION/en/Detail/Index?id=3662665235866169729&appLang=en&os=Win64


#138

Another tested workaround: http://www.qcad.org/en/

Load the “bad” DXF in QCAD and save it as either an SVG or an R15 DXF. Unfortunately, downgrading from QCAD Professional to the free edition seems to remove both of these features. You can still export to PDF, but it creates some seriously duplicated paths.


#139

Muchas gracias gentlemen! Will run them through their paces (hopefully) tomorrow. :grinning:


#140

I haven’t posted any new videos in a while, so I figured I would change that.
Part 04 of 06 is now live on YouTube here: Fusion 360 for Glowforge Users - Part 04 of 06

Note: It might take a few more minutes for YouTube to finish processing the video.

Cheers,
Jason


#141

Did I miss the webinar? Or are you just uploading the vids for the rest?