Glowforge stuck in cancelling - tried all the things

This is my second GF. My first had to be returned because it went “offline” and stopped putting out a wifi signal, so I’m already behind on orders an feeling stressed.

I just unboxed the new unit and am totally struggling with getting it to work. I spent a couple hours trying to get this new GF to connect to a device, and finally was able to get connection to wifi, via my computer, after trying everything in the book and then finally having it magically connect. After struggling for another half to get my artwork to load, I switched browsers from safari to firefox and was finally able too get the app to respond and load work. I loaded my first project and hit print and everything seemed to go fine. The print finished, the laser head went back to its home, and I let it cool for several minutes before opening the lid. Then I noticed the countdown timer was still going, so I hit cancel.

Now it is stuck on canceling. I turned to the forum and see that this issue has happened to many others, so I went through all the advice given to them. So far, I have tried the following:

•logged out and logged back in
•turned off the GF and turned it back on- several times.
•turned off GF, computer and wifi router, let sit for a couple minutes and turned back on - 5+ times
•loaded Chrome and tried to use the app on its browser.
•opened the GF app in two separate browsers to try the “print and switch”, but it is stuck in canceling in all browsers I open.

The wifi is in the same room as the GF and they are less than 10 ft apart with no interference. The only devices currently on the wifi are the GF and my computer.

I’m not sure what else to do.

Please help,

1 Like

I have not had any problems with cancellation but for the last month I have noticed some very odd things with the interface.

The clock does not run down but the machine is still lasering and after a print gets finished the only time I get the final message is after I refresh the browser.

Make sure your network is set on 2.4 and delete your cache.

Thank you for your response. I am on a 2.4 and I have cleared all the cache. The GF then went offline for a couple hours, and I finally got it to reconnect and it was no longer in cancelling mode. I was able to do one print, but now it has disconnected again.

Ugh. so frustrating

It does seem like a WiFi issue to me. Is it possible that one of your neighbors’ WiFi is interfering? One thing people have done is to go into their router settings and change the channel to a different one. Sometimes that helps.


I’m sorry for the ongoing trouble and that your Glowforge is going offline and getting stuck while cancelling. Thank you for the detailed information about what you’ve tried so far.

Network-specific Wi-Fi challenges may occur for a number of different reasons. I do have a few additional suggestions that may help:

  • If your Wi-Fi network includes several access points, it’s possible that your Glowforge needs to re-establish its connection whenever it ‘hops’ from one access point to another. As a test, you could try creating a dedicated access point for the Glowforge to see if that helps.

  • Though less common, DNS or name resolution conflicts may also cause intermittent connectivity problems. If you use a custom DNS configuration on your router, you might want to try default DNS settings to see if that works better.

If you’re still having trouble, there’s a test you can try that will help us narrow down the problem. If possible, could you please create a Wi-Fi hotspot with a cell phone and use that network to connect your Glowforge to Wi-Fi? This is a good way to rule out certain issues.

You can find instructions online to help you create a Wi-Fi hotspot using a cell phone. Make sure that you set it up to be a 2.4 GHz hotspot, since that is the frequency your Glowforge uses.

Once the Wi-Fi hotspot is broadcasting, you can connect to it by following these steps:
  1. Turn on your Glowforge.

  2. Wait 30 seconds. Then hold down the button for ten seconds until it glows teal.

  3. Go to and then follow the steps to connect your Glowforge to Wi-Fi. When prompted to connect, select the hotspot you created.

  4. Once Wi-Fi setup is complete, go to and try a few prints.

To see the Wi-Fi setup process in more detail, go to Connect Your Glowforge to WiFi. Please let us know how it goes!

Hello, Thank you for your response.

Now the issue seems to be with even getting my new GF connected and online.

I called my internet provider and they are sending me a “pod” that i can dedicate to the GF, but it wont be here for a couple of days.

The GF WIFI signal seem to be extremely intermittent, only popping up as an option every now and then. When it does pop up as an option, I try to connect my computer and I get a notice that I am unable to connect to the network. It worked last night for 1 print and then went “offline” again.

I have tried to hook the GF to my phone by using my hotspot, but the GF only pops up as an option intermittently, and when i try to connect to it, I get a notification that I able “unable to join the network”. I have tried this option over and over again and have yet to get a successful connection to my phone.

•My WIFI only has one access point.
•I moved the router so it is less that 2 ft away from the GF and I have removed all other devices from the 2.4 network.
•I have reset every piece of equipment that I own, in the order I have seen suggested on the forum.
•I have unplugged each piece of equipment.
•I do not have a custom DNS

Thank you for these additional details. I think a good next step might be for our team to set up a time to give you a call so that we can troubleshoot this further together in real time. May I reach out to you via email with next steps and information on how we can get the call scheduled?

please do

Do you have an Apple TV on your network?

No, we do not have Apple TV

1 Like

My Apple TV was causing all of my issues an was hoping it was just something that simple.


Hi @thedrifthandmade - since we connected in chat recently I’m going to go ahead and close this ticket so we can make sure all our troubleshooting is happening on the same thread.