Glowforge stuck on Centering/Homing

Hey community, I’ll probably need supports help but until they can respond, do you have any ideas?

I’ve reboot internet connection, connect to hotspot, clean machine, but nothing is working. I haven’t even had my machine for 30 days yet. It worked just fine on yesterday. It’s a bummer that this is happen.

I just had a similar issue about two weeks ago. Mine was my google wifi mesh network - spent literally hours tracking the issue down. Finally gave up after several hours of trouble shooting only to wake up in the morning with a message from google and my laser working again.

I forgot to mention, I had other devices in the house such as my sonos speakers and smart plugs that went out during the same time I was having troubles with centering/homing. So check your other devices as it might be some insight that is your internet.

If it is not the internet, I had another time in which it was the cable that runs along the backside to the camera. Had to replace that and I was up and running again.

Thanks for that info. My husband is doing some troubleshooting right now. So hopefully it will be up and running by the time I hear from support. Just another thought…could the servers be overloaded with people working their businesses for the holidays? Makes me wonder.

The centering/homing issue is usually a client based issue. The Glowforge servers aren’t involved at that point.

Also, they use Google servers that scale up and down with demand so, usually not but Google has had issuesthat affected GF…2, maybe 3 times since GFs were shipped years ago. @dklgood is correct that it’s is nearly always a local issue.

The homing process (and everything else) is driven by the cloud. The reason wifi affects it is precisely because it needs to send images to the server to figure out where the laser head is, and receive movement instructions back.

1 Like

Got it. Thanks

Hello @andrasheridan - I’m sorry to hear you ran into this trouble.

I extracted the logs from your Glowforge to look into the issue further and it appears you were able to run a couple of prints after reaching out to us, that’s great!

Looking at the issue around the time you reached out, it looks like the printer was having a bit of trouble maintaining a network connection.

If you see this trouble continue or return I’d like to recommend the following steps:

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

I hope this helps. As you look to be back up and running I’m going to go ahead and close this topic, but feel free to reach out via email at if you have any additional questions or issues.