Glowforge stuck on centering still

My glowforge arrived in December of 2019 and the first time I turned it on, it wouldn’t work. Hours of my machine stuck on centering.

In January, after receiving the new cable, I finally tried to get the machine to work and it did. And then the second time I turned it on, centering issues again.

Fast forward to August after I was laid off due to COVID, I finally decided to give the machine another try so I could earn some income. Another kind glowforge user walked me through how to use Adobe either my machine. And with her on FaceTime, I turned on the machine, and it wouldn’t work. About an hour into the conversation and going through the processes that are constantly repeated on the forums, it worked again.

I hate to say that every time I turn on the machine, I have anxiety, but it’s true. I ended up getting another cable replacement in September and after the first use with the new cable, it continued to get stuck on centering. Over and over again.

I turn on the machine, it goes through everything until centering, and then it stops. I reset the internet, check the cables, clean everything, try the lid trick, try the head under the camera trick, and I go through this for HOURS just to have the machine decide to work. EVERY TIME!

I hate to be ugly, but I am a customer who bought an extremely expensive machine with issues from the start. I am so sad. This machine has not saved my business time whatsoever. I’ve been sitting with my machine for two hours this morning and it will not work. I’m going to have to refund my orders, which are my only job right now, just to keep customers happy if I can’t get my machine working by this weeks deadline.

It can’t be a cable issue with it being brand new. It wasn’t a cable issue when the machine was brand new and didn’t work from the start. I am at a lost for words with a machine that is less than a year old. And now I’m stuck with a brick and no way out.

I’m so sorry Glowforge for my bluntness, but I’ve tried to be supportive even on social media. This feels like a problem that will never be fixed.

Actually, it can, but support will be able to verify from the logs.

The lid cable and associated connectors are an incredibly poor design.


I just had to refund a customer $50 and walk away from the machine for today.

Sounds more like wifi to me. Have you tried connecting using a cell phone hotspot?


I’ve reset my router, reconnected the internet trying on the same PC I’ve been using and I’ve tried my phone. No fix

Okay. Wifi we could have helped with, but if you connected it to a phone hotspot and that didn’t work, we’ll just have to wait for Support to get here. Sorry!

1 Like

I’m so sorry about the continued trouble you’ve experienced with your Glowforge, and for the frustrating experience you’ve had so far.

I appreciate you letting us know that the cable has been replaced multiple times, and the same snag is occurring. This may indicate that it is related to a deeper error, so I’d like to take a look at the clip connections your cable snaps into, just to make sure everything is correct.

Could you please send us photos of the three connections, like these examples below? When we receive them, we will take a close look at the connections and follow up with next steps.

Once we can review these images, we’ll send over any additional steps. Our main priority is to get you back up and printing as soon as possible, so if everything appears to be correct, we’ll make sure to take care of it.

1 Like

Thank you so much for your response. I’ve included my images here!

Thank you so much for helping! I just had to refund a customer $50 so I was feeling extremely disheartened :heart:

1 Like

Hi Marc, I appreciate your time. Are there any updates on this? I’ve tried multiple WiFi/hotspot sources as well. My glowforge is still not working today and I’m terrified I’m going to have to provide more refunds to my customers than I already have.

@tausha, Thank you for posting those photos. The clips and cable connections all look good, which leads us to believe the problem is something deeper in your Glowforge. As this is an issue you’ve been dealing with since first receiving your Glowforge, we are going to go ahead and get a replacement unit sent out to you.

As a part of the replacement process, we’ll need to confirm some personal information, so I’m going to move the rest of our communications over to email. You should receive an email from me in the next few minutes. If you don’t receive it within 30 minutes, please check your spam / junk mail folder. Once I know you’ve received the email, I’ll close this forum thread.

Having just replaces the black cable I can easily see how it can be broken or almost broken just installing it. Mine now works (on the 4th try) but it was grateful surprise that it did.

@tausha, I see that my email was received. I’m going to go ahead and close this thread now.