Glowforge stuck on last bed image but says it is ready for cut?

Hi there,

My glowforge is stuck on the last bed image that was taken last night. It is not stuck on calibrating and actually says it is ready to print but the image is not correct.

We have tried the following, which was found through similar posts but nothing has seemed to work.

We have restarted
Cleared cache
Restarted computer
Restarted Wifi
Restarted App
The machine was cleaned two days ago
Unplugged the machine and left it unplugged for a few minutes before restarting.
The machine has not been moved since date of installation and has worked fine up until now.
We made sure that the GF was connected to the correct WIFI.

When the machine turns on, it does the normal routine of the laser moving and it looks like it is calibrating but then when it is scanning, it just shows the last image.

Any input would be greatly appreciated.

Having the same issue and did all the same things you did, thinking it might be a software issue then.

That is what I am thinking it might be? It was working perfectly last night and as soon as we turned it on this morning it did this.

same here - maybe their servers are down

I’m really hoping it’s just a server issue and my machine isn’t having any major issues.


Thank you for letting us know about the issue with the image on screen in the Glowforge App not updating. The trouble should now be resolved. Please refresh your browser window and the bed image should update.

If you are still having trouble after receiving this message, please let us know.

On behalf of the whole team here at Glowforge, I apologize for the inconvenience.

Kind regards,