Glowforge won’t connect to Wifi

I’m hoping I can get some help. I recently purchased a Glowforge Plus. I am running into an issue trying to complete the device setup. I am able to connect to the Glowforge to start the setup. However, when trying to connect the Glowforge to my home wifi, it gives the “Glowforge Didn’t Connect” error. I have confirmed the password is correct.
My home wifi is 802.11n 2.4GHz with WPA2-PSK security mode. I also tried rebooting both my modem/router and the Glowforge and still received the same error. I also confirmed that I have a strong wifi signal where the Glowforge is located. Please advise of any further steps I can take.

Welcome to the forum!

Sit tight, someone who understands networking will no doubt be along soon to assist. (It’s Sunday…fewer folks hanging around.) If not, support will be able to help when they check in.

Try using your phone as a hotspot and connect the machine to that. If that works fine, then it’s likely an issue with the strength of your wifi signal, in which case you can relocate the machine, or the router if possible.


I can see that you’ve also submitted an email request and that we have responded to you there. I’m going to close this topic to avoid miscommunication. I hope the advice the other community members have given has been helpful!