Going to need black cable

1st time happened.

This is what I have done so far.

Powered down. Removed crumb tray. Checked all contact points and made sure clean and clear of debris. Closed doors and powered up and continue to get Lid Open error. Machine is in same location it has been in for some time with no errors so it is sitting correctly.

Need to get black cable I am guessing. Machine no longer in warranty.

Please advise.

Thank you

Have you checked the troubleshooting steps here:

It’s not “official” GF info but has been consolidated from many previous threads here.


Thank you and yes I have.

Still no reply from support.

It can take a few days to hear from Support - especially with a weekend coming. You’ve opened a ticket so they will get back to you! Don’t open any new tickets or send an email - that’ll just slow it down

I’m sorry about the trouble with your Glowforge. Thank you for providing detailed information about what you’ve tried so far. I’m going to close this thread and reach out to you via email with next steps.

1 Like