Help! Can’t figure this out with affinity designer

bubble i cannot for the life of me figure this out. This is apart of a design I drew out. Everything is great besides this. It just engraves the entire inside of the bubble instead of the little quotes inside. It’s a curve, fill only, transparent… I used shapes to make this with the subtract tools. It looks fine on here but when putting it into the glow forge the entire thing is highlighted. I followed the same steps as all the other icons I made. It’s just this one that I don’t know what happened.

This is what is looks like on the interface

There is just one object there and it should engrave as it shows, but it would highlight as one thing that it is.

Im trying to upload the actual file and not sure how… lol. It isn’t engraving as it shows. The entire thing is highlighted, not just the outside of the bubble and the two little things inside.

If you could engrave it on a piece of : :proofgrade: scrap and post a photo of it here Support will see better what you are talking about and could fix the problem easily on their end. Or rather they will see with either a P&S section post or an email but not both

Okay!

1 Like

This might help. I just created a rounded rectangle to quickly duplicate (sort of) your design. When I exported it as SVG, I had the same issue you have. It wants to engrave the entire rectangle including the negative space inside it. On top of that, it reverted to a single thin stroke rather than the thick 17 point stroke in my design.

However, I then went back to AD and chose to “Rasterize” (make pixels) out of my rounded rectangle before exporting it. It then appears correct in the Glowforge interface with my 17 point stroke and nothing in the negative space inside the rectangle. You might try this.

I was thinking of doing that too. But when I did it, it caused it to be all pixely. Wouldn’t it show up that way when printed?

I’ve not had that issue but I cannot speak with authority. You might just try it on scrap.

1 Like

Pull it out and make the image really big and then scale it down, and it won’t be pixely. But start a post into P&S with the image as it is a bug in the system they need to fix.

Reread your other comment and was just about to to that. Thanks for the tip! I will try that.

One other thing to try. Select your rounded rectangle, convert it to curves, then choose “Expand Stroke” in the Layer menu. This had the same positive outcome in the Glowforge interface as when rasterizing… only without the pixels.

I tried that as well… maybe I’m not doing it correctly because I’m still new. But when doing that it just leaves the outline. I did delete the fill of it though. Are you saying to expand the stroke and leave it as is?

Then you can place the quote marks inside the empty rectangle as a separate piece of art.

This is a well-known bug in the Glowforge UI. It doesn’t support “fill-rule: evenodd” in SVG, which this file uses.

Several solutions:

  1. You can export as PDF instead. Glowforge does support the evenodd fill rule in PDFs, just not in SVG.
  2. You can change the shape to use the nonzero fill rule and then reverse the direction of some of the paths. (This is a pain; I don’t suggest it.)
  3. You can rasterize the shape. You should go into the Document Setup settings in Affinity Designer and bump the DPI up to 300 or so to make sure it rasterizes it at a high enough resolution.
  4. Glowforge could fix the bug. (Don’t hold your breath. I reported this over 3 years ago and they still haven’t fixed it.)

Personally I’d just save it as PDF. There’s a bunch of stuff that just works better in the Glowforge interface if you use PDF. (There are some exceptions, but for the most part their PDF support is better than their SVG support.)

4 Likes

Can try this one, I brought it into inkscape broke it apart with CTRL-SHIFT-K then then exclusion on it by selecting everything and pressing CTRL-SHIFT-6 under path and it seems to work on my dashboard.


bubble

Thanks, Tim, for the explanation. That’s good to know.

1 Like