HELP - Problems with replacement Glowforge

My replacement Glowforge arrived and will not connect to the internet, the laser head will not move and I have done everything (turning off phone, routers, restarting, placing the head over the logo, reconnecting the head, pressing the button so the blue light comes on because that does not come on by itself). I have sent an email for help Monday and no response. Just sent another. What am I doing wrong! At least the old one connected to the internet! Anyone have suggestions? I already sent the old one back or I would have tried that head.

You’ve now opened three support tickets. (Two by email, one by posting here.) It can take support a little while to respond because they’re working their way through all the open tickets, so be patient. They’ll get to you.

(I know it’s super tough to wait…been there myself a few times! But opening more tickets just makes it slower for everybody; it doesn’t get you a response any sooner.)

While you’re waiting, maybe check your spam folder just to be sure you haven’t missed a reply.


Yes I know…I was just asking the community to see if someone had any other idea (I have been looking over all the posts / tried what I have found and was hoping it was something simple or stupid that I was doing wrong). I know how busy they are, I have been patiently waiting since April and was hoping that it could be solved this way instead of having to take up more of their time and mine.

I’m so sorry we missed your email on Monday.

I see you already emailed us about this and we’re working on it there, so I’m going to close this topic.

I’ll also follow up regarding the missing emails.