Help with printing

I have connected to wifi and I am trying to do my first print with the key chain. It will not let me print and it says I need to connect and reboot. I have done all that with no luck.

I have made it past this step. Now it is stuck on uploading.

Maybe try giving your computer/router a reboot? Seems like a potential connection issue.

I have done this.

If you can, try using your phone as a hotspot for the GF and see if it works any better.

Not having any luck with connecting to my phone.

I extracted the logs from your Glowforge to investigate, and it looks like Wi-Fi setup was successful, but you received an error message anyway. I’m so sorry about that.

Could you please do the following for me?

  1. Exit the web browser you are using.
  2. Turn off your Glowforge.
  3. Wait at least 10 seconds.
  4. Turn on your Glowforge. (Please do not touch the button on top of the Glowforge - only the switch on the back).
  5. Once the Glowforge is on, wait two minutes so it can calibrate and apply any necessary updates.
  6. Open your web browser and navigate to
  7. If your dashboard loads with designs, you’re all set - you can start printing! If you see anything else, let me know.

If at any point during these steps, the button on top of your Glowforge glows with any color other than white, let us know.

The designs loaded but it says offline.

Thanks for letting us know. I took a look at the latest connection activity from your Glowforge, and I’m seeing a large number of connections in a short span of time. Around the time of your last comment, shortly after 1:00pm Pacific, your unit connected, then disconnected, five times in a ten minute period. I’ve seen this occur before, and it indicates that your Glowforge was able to connect successfully to your network, but it may be having trouble maintaining a stable connection. When this is the case, you won’t need to go through Wi-Fi setup again, but you may see an “Offline” message.

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

I hope this helps. Please let us know if you’re still running into trouble after trying these steps.

It’s been a little while since I’ve heard back from you. I hope that’s because everything worked out! If not, just let me know and we’ll get it solved.

Hi Josh, I don’t have it running yet. It looks like I am going to have to get the wifi closer to the machine. I am hoping to do this soon.

I got it up and running now, thanks.

I am so glad to hear you are back online and printing! If you run into any other trouble please feel free to start a new thread or email us at

Happy Printing!