Help with upload to GF — engrave isn't coming through correctly


I’ve been using my Glowforge for about a month and LOVE it, but I’m stuck right now and really need your help.

I thought this would be a pretty simple project. I’ve done something like it before and it worked great, but this file it just won’t work. What am I doing wrong?

I created a vector file in Affinity Designer on the iPad Pro (my normal workflow). The file has 2 layers: one for the cut and the other for the engrave. The cut layer is red. The engrave layer is yellow. Then I exported the SVG as I always do, starting with SVG for Export, then changing to “Use Document Resolution,” “Text as Curves,” and “Flatten Transforms.”

I uploaded the file to the Glowforge app and when I select “Engrave” for the layer I want engraved, it leaves out key engrave lines, however when I select “Score,” it the lines are all there as expected. Trouble is, I need them to engrave, not score.

Any ideas?

Here are the Affinity export settings I used:

Here’s how the file comes in:

These are my engrave settings:

When I switch the layer to “score” all the lines are there, though:

And, in case it helps, here’s the SVG file:

Thanks to anyone who can help!


1 Like

You actually gave enough information in your description to be able to tell you what is going on with that file (good thing!) …so here you go…

There’s nothing really wrong with your file, but you are using Affinity Designer to create a compound path, and based on their winding rules and the way that the Glowforge interface interprets them, it is going to create a problem for you. It’s a known issue.

The workaround is to rasterize the name portion of the file, (or make a bitmap copy to use for the engraving), while leaving the cut line as it is. I believe I have also seen that saving the file as a PDF can work in these instances. (Instead of an SVG.)

Or you can create the SVG file in AI or Inkscape and it doesn’t have the issue, so I did that real quick below.


I don’t use AD enough to be able to tell you if you can fix it in that program but someone else might.


Jules, thank you so much! I’m going to try a PDF, first. If that doesn’t work, before I create a bitmap of the engrave, do you know if importing the SVG to Inkscape would solve it?

Either way, thank you thank you thank you!!


No problem, and I fixed it in AI, because that’s what I use, so I’m not entirely sure what to do in Inkscape. Someone else might though. :slightly_smiling_face:

No problem at all! In fact, I was able to save as PDF and it worked, just as you thought it would. YAY!

You made my day!!


1 Like

I’m glad you resolved it! Thank you @Jules for your advice. I’m going to close this thread. If you run into any other trouble, please start a new topic, or email us at We’re here to help!

1 Like