How to cancel a stuck file upload?

I’m having occasional upload issues with the UI. Sometimes when I try to upload artwork for printing, the Glowforge app will seem to freeze. The file never uploads, and if I try to upload it again, I get this dialogue box:

Problem is, that upload NEVER completes, and after waiting anywhere from 15 to 30 minutes with no change, I have to completely close out of the browser (sometimes losing my design progress) to clear the upload and try again. This afternoon I have been trying to upload my file (which I know is compatible with the GF app, as it’s a design element I’ve printed before) for two straight hours, and I still have nothing to print.

I wondered if this might be an issue with internet speed – sometimes my service isn’t super great – but even with a slower-than-average connection, it still shouldn’t take half an hour to upload a 1.4MB file! (I mean, I’m not on dialup.)

Is there any way in the app to manually cancel an upload, or am I stuck just doing what I’m doing and starting over when this happens?

I haven’t seen that in years, but early on in development we sometimes saw this and @takitus discovered that if you open another tab in the browser and load a simple file that processes quickly, like a circle, and let it process all the way till the button flashes - then cancel that op and return to the original tab it would be cleared.
As I said, I haven’t seen that for years, so I suspect another issue, but you could try that.


I’m so sorry you hit this snag! But thank you for including the image of the error.

Does the trouble only occur with this particular design, or has it happened with other designs? If you switch to a different browser, does the same error show up?

It has happened several times with different designs, but it’s so random that I can’t reliably replicate it (which is why I wondered if it were a connection issue, but if so it doesn’t seem to be on my end, as speed tests and other internet functions are still fine).

I haven’t tried another browser, as Chrome is the only one I use on my tablet. (It’s a Windows machine so it probably has Microsoft’s default browser installed somewhere, but I’ve never used that for anything.) I think I may still have an older laptop with Firefox installed, but since all my graphic design software is on the tablet, I’ve never tried to use it with the Glowforge.

Thank you for updating us! I apologize for the delay in response.

I’ve extracted the logs from your Glowforge, and it looks like the file you were experiencing trouble with was able to be uploaded and you did not hit the same snag.

Could you let me know when the next time the error inside of the app occurs? Including the date and time of the upload/print would be very helpful.

Have you tried just refreshing the page? I’ve had a few get stuck, thanks to occasionally bad internet, and the only way to “cancel” the process that I’ve figured out is to just refresh the page.

There was the old trick that we used to have to use where occasionally someone couldn’t get past the frozen upload so they’d have to open a new browser to the app on another machine and upload a new file - that would work and free up the first session. That first session could be closed and reopened fresh and then the original upload would work.

Been a long time since I’ve seen anyone refer to needing to do that so I suspected they fixed some kind of file lock on their end but maybe that gremlin is back.

We’ve made a change on our end. Would you please restart your Glowforge, restart your browser and then re-try your print and let us know if the trouble persists? Thank you!

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email