Ignoring curve of SVG node(s)

A file I have cut before with zero problems. I’ve reviewed the file within Illustrator, copied, reworked the outline… all looks correct on screen in Illustrator (both AI file and SVG), looks correct on GFUI screen…

One curve of the the outline is ignored as if it’s an “open” shape, and cuts a straight line between two nodes.

First (left) “section” shows first cut, caught me by surprise, so I paused and then cancelled. All lines were one step (cut). Yes, I know, the material isn’t flat. Just mat board.

Middle: Reviewed and re-saved(AI) and re-uploaded the file. Same result. I let it finish the cuts (outline was last step, I had made it into it’s own step) Hmmmm…

Third: complete reworking of the file in AI. Added the stand alone “outline” (which is the top step in the GFUI on the left). Same result on both outlines. You can see the actual cut (straight line, bottom right of image) vs. the file (redline).

Lil’ help. :slight_smile:

It would seem this is a file problem (I hope). But I’m unable to resolve it. And, of course, I’d like to prevent this on future files, this one in particular.

I also want to make sure that if this IS a GF issue, you guys are aware of it, AND get it sorted within warranty time.

Here is the AI file.
BirdheadNotebookSize.ai (1.5 MB)

And the resulting SVG.

1 Like

Your file looks okay to me. I didn’t try cutting it. What happens if you go to the Attributes panel and change the Use Non-Zero Winding Fill Rule to Use Even-Odd Fill Rule, for the paths that misbehave? I have no idea why this would help but have seen some funny things happen that changes in the Attributes panel fixed.

Good luck!


Well that was interesting. I tried a bunch of things that absolutely didn’t work the way I expected them to…until I got to the slope of that curve. Changing it by just a hair causes it to print curved.

Cutting it separate, changing the color, cutting at the corner to force it to start in a particular place, rotated, non-rotated, copied, non-copied…none of them worked.

So try this one Birdhead reworkd.zip (1.8 KB) and see if it works any better. That definitely looks like a bug in the Glowforge rendering software, and that might take a while to track down.


Sorry @cynd11, yours didn’t work. :confused:

@Jules, your reworkd file did work. THANK YOU! But yea, I was about to try all of those things tonight. Usually, a quick reboot, then cut&paste into a new file settles odd lil’ things like this. Because it was only those two nodes though… just makes zero sense.

Glowforge Staffer(s) checking this thread… I’m cool with my file, I can get the things made for my dayjob that I need. But I’d REALLY like to know what happened here. (I suspect Jules would too.) So please don’t consider the ISSUE closed, even though my immediate problem is solved.

Thank you ALL!

It is also making me a bit nervous… it seems Jarvis is needing a reboot (off and then on again) after every cut tonight. Getting stuck on centering or scanning. :frowning:

Still functioning normally after the reboot. But constant rebooting is new. (Usually MAYBE once per long burn session. And this is a short sesh.)

1 Like

Regarding your design not printing as expected, thank you for letting us know about this, as well as for the detailed information. I’ve let the team know and they’re investigating the issue.

Regarding your recent need to reboot, would you please let me know if the issue is still occurring? Thank you!

Next crafty burn session won’t be until Wednesday or Thursday evening. Will definitely keep tabs on it. Thank you, Ivan!

Hey @ivan1, short burn session tonight… 3 prints: 1.etch/cut, 2. ignored etch and cut a second pass (without opening the lid), then open the lid, switched material, uploaded a new file, reboot required for 3rd. Got stuck on scanning as before. Not sure if it’s important, but I DID use the autofocus on the 1st etch.

Next session(tomorrow maybe), I’ll test not using the autofocus.

Thank you for the detailed information about your most recent session. The details you provided helped me to locate the prints you’ve referenced.

I extracted the logs from your Glowforge to investigate the issue, and it looks like your unit may be experiencing intermittent upload failures due to host name resolution trouble. If you use a custom DNS configuration on your router, you might want to try default DNS settings to see if that works better.

If you’re still having trouble, there’s a test you can try that will help us narrow down the problem. If possible, could you please create a Wi-Fi hotspot with a cell phone and use that network to connect your Glowforge to Wi-Fi? This would be a good way to see if the issue persists when using a different network.

You can find instructions online to help you create a Wi-Fi hotspot using a cell phone. Make sure that you set it up to be a 2.4 GHz hotspot, since that is the frequency your Glowforge uses.

Once the Wi-Fi hotspot is broadcasting, you can connect to it by following these steps:

  1. Turn on your Glowforge.
  2. Wait 30 seconds. Then hold down the button for ten seconds until it glows teal.
  3. Navigate to setup.glowforge.com and follow the instructions on-screen. When prompted to connect your Glowforge to Wi-Fi, choose the hotspot you created.
  4. Once Wi-Fi setup is complete, go to app.glowforge.com and try a few prints.

Please let me know how it goes!

I’ll try that this weekend. I use default settings on my router. (I don’t know enough to dive into custom configs.)

If you’ve had a chance, just let us know how it went. Custom configurations usually aren’t needed to use your Glowforge, so DNS settings are unlikely to be an issue if you haven’t made any customizations.

Another thing you might want to check (and this is a very easy thing to change once you know how) is the Wi-Fi channel your network is using. Simply take a look at your router documentation to see how to change the 2.4GHz Wi-Fi channel, and try changing it (1, 6, and 11 are recommended).

Regardless, please let us know how the hotspot test went! Thanks again.

Haven’t had a chance to test and futz around. Last big market coming up this weekend until November… So gotta push through with burning… but I WILL test all of this, but it’s definitely gonna take me awhile to get the “free” time to experiment. Sincerely appreciate the follow-up.

It’s been a little while since I’ve seen any replies on this thread so I’m going to close it. If you still need help with this please either start a new thread or email support@glowforge.com.